Closed Bug 1679271 Opened 10 months ago Closed 10 months ago

Broken build in accessible/base/NotificationController.cpp after recent change

Categories

(Core :: Disability Access APIs, defect)

Other
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1680269

People

(Reporter: dan, Assigned: dan)

Details

Attachments

(1 file)

I am getting a build failure on ppc64le and s390x platforms after a change that went in the last ~24 hours. Seems the problem is a missing included header which is indirectly included on other platforms.

 0:13.71 /usr/bin/g++ -std=gnu++17 -o Unified_cpp_accessible_base0.o -c  -I/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/stl_wrappers -I/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/system_wrappers -include /mnt/dan/firefox.git/config/gcc_hidden.h -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 -fstack-protector-strong -DDEBUG=1 -DOS_POSIX=1 -DOS_LINUX=1 -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -DSTATIC_EXPORTABLE_JS_API -I/mnt/dan/firefox.git/accessible/base -I/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/accessible/base -I/mnt/dan/firefox.git/accessible/generic -I/mnt/dan/firefox.git/accessible/html -I/mnt/dan/firefox.git/accessible/ipc -I/mnt/dan/firefox.git/dom/base -I/mnt/dan/firefox.git/dom/xul -I/mnt/dan/firefox.git/accessible/ipc/other -I/mnt/dan/firefox.git/accessible/xpcom -I/mnt/dan/firefox.git/accessible/xul -I/mnt/dan/firefox.git/dom/base -I/mnt/dan/firefox.git/ipc/chromium/src -I/mnt/dan/firefox.git/layout/generic -I/mnt/dan/firefox.git/layout/style -I/mnt/dan/firefox.git/layout/xul -I/mnt/dan/firefox.git/layout/xul/tree -I/mnt/dan/firefox.git/accessible/atk -I/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/ipc/ipdl/_ipdlheaders -I/mnt/dan/firefox.git/ipc/chromium/src -I/mnt/dan/firefox.git/ipc/glue -I/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include -I/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/nspr -I/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/mozilla-config.h -Wall -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wc++2a-compat -Wduplicated-cond -Wimplicit-fallthrough -Wunused-function -Wunused-variable -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=coverage-mismatch -Wno-error=free-nonheap-object -Wno-multistatement-macros -Wno-error=class-memaccess -Wno-error=deprecated-copy -Wformat -Wformat-overflow=2 -Wno-psabi -fno-sized-deallocation -fno-aligned-new -fno-exceptions -fno-strict-aliasing -fno-rtti -fno-exceptions -fno-math-errno -pthread -pipe -g -Og -fno-omit-frame-pointer -funwind-tables -I/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/cairo -Wno-error=shadow  -MD -MP -MF .deps/Unified_cpp_accessible_base0.o.pp  -fdiagnostics-color  Unified_cpp_accessible_base0.cpp
 0:18.91 In file included from Unified_cpp_accessible_base0.cpp:128:
 0:18.91 /mnt/dan/firefox.git/accessible/base/NotificationController.cpp: In member function ‘virtual void mozilla::a11y::NotificationController::WillRefresh(mozilla::TimeStamp)’:
 0:18.91 /mnt/dan/firefox.git/accessible/base/NotificationController.cpp:597:62: error: ‘OTHER’ was not declared in this scope
 0:18.91   597 |   AUTO_PROFILER_LABEL("NotificationController::WillRefresh", OTHER);
 0:18.91       |                                                              ^~~~~
 0:18.91 /mnt/dan/firefox.git/accessible/base/NotificationController.cpp:597:62: note: suggested alternatives:
 0:18.91 In file included from /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/ProfilingStack.h:15,
 0:18.91                  from /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/RootingAPI.h:27,
 0:18.91                  from /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/Exception.h:13,
 0:18.91                  from /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/ErrorReport.h:31,
 0:18.91                  from /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/mozilla/ErrorResult.h:34,
 0:18.91                  from /mnt/dan/firefox.git/dom/base/nsINode.h:19,
 0:18.91                  from /mnt/dan/firefox.git/dom/base/nsIContent.h:10,
 0:18.91                  from /mnt/dan/firefox.git/accessible/base/ARIAMap.h:16,
 0:18.91                  from /mnt/dan/firefox.git/accessible/base/ARIAMap.cpp:8,
 0:18.91                  from Unified_cpp_accessible_base0.cpp:2:
 0:18.91 /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/ProfilingCategoryList.h:34:18: note:   ‘JS::ProfilingCategory::OTHER’
 0:18.92    34 |   BEGIN_CATEGORY(OTHER, "Other", "grey") \
 0:18.92       |                  ^~~~~
 0:18.92 /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/ProfilingCategory.h:38:71: note: in definition of macro ‘SUPERCATEGORY_ENUM_BEGIN_CATEGORY’
 0:18.92    38 | #define SUPERCATEGORY_ENUM_BEGIN_CATEGORY(name, labelAsString, color) name,
 0:18.92       |                                                                       ^~~~
 0:18.92 /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/ProfilingCategory.h:42:3: note: in expansion of macro ‘MOZ_PROFILING_CATEGORY_LIST’
 0:18.92    42 |   MOZ_PROFILING_CATEGORY_LIST(SUPERCATEGORY_ENUM_BEGIN_CATEGORY,
 0:18.92       |   ^~~~~~~~~~~~~~~~~~~~~~~~~~~
 0:18.92 /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/ProfilingCategoryList.h:35:24: note:   ‘JS::ProfilingCategoryPair::OTHER’
 0:18.92    35 |     SUBCATEGORY(OTHER, OTHER, "Other") \
 0:18.92       |                        ^~~~~
 0:18.92 /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/ProfilingCategory.h:24:71: note: in definition of macro ‘CATEGORY_ENUM_SUBCATEGORY’
 0:18.92    24 | #define CATEGORY_ENUM_SUBCATEGORY(supercategory, name, labelAsString) name,
 0:18.92       |                                                                       ^~~~
 0:18.92 /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/js/ProfilingCategory.h:27:3: note: in expansion of macro ‘MOZ_PROFILING_CATEGORY_LIST’
 0:18.92    27 |   MOZ_PROFILING_CATEGORY_LIST(CATEGORY_ENUM_BEGIN_CATEGORY,
 0:18.92       |   ^~~~~~~~~~~~~~~~~~~~~~~~~~~
 0:18.92 In file included from /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/mozilla/Telemetry.h:11,
 0:18.92                  from /mnt/dan/firefox.git/accessible/base/NotificationController.cpp:17,
 0:18.92                  from Unified_cpp_accessible_base0.cpp:128:
 0:18.92 /mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/dist/include/mozilla/TelemetryHistogramEnums.h:4696:3: note:   ‘mozilla::Telemetry::LABELS_EXTERNAL_PROTOCOL_HANDLER_DIALOG_CONTEXT_SCHEME::OTHER’
 0:18.92  4696 |   OTHER,
 0:18.92       |   ^~~~~
 0:18.94 In file included from Unified_cpp_accessible_base0.cpp:128:
 0:18.94 /mnt/dan/firefox.git/accessible/base/NotificationController.cpp:597:3: error: ‘AUTO_PROFILER_LABEL’ was not declared in this scope
 0:18.94   597 |   AUTO_PROFILER_LABEL("NotificationController::WillRefresh", OTHER);
 0:18.94       |   ^~~~~~~~~~~~~~~~~~~
 0:20.50 gmake[4]: *** [/mnt/dan/firefox.git/config/rules.mk:676: Unified_cpp_accessible_base0.o] Chyba 1
 0:20.50 gmake[4]: Opouští se adresář „/mnt/dan/firefox.git/obj-powerpc64le-unknown-linux-gnu/accessible/base“

proposed fix

diff --git a/accessible/base/NotificationController.cpp b/accessible/base/NotificationController.cpp
index 749bc8c02eb..60eb90d6a72 100644
--- a/accessible/base/NotificationController.cpp
+++ b/accessible/base/NotificationController.cpp
@@ -5,6 +5,7 @@
 
 #include "NotificationController.h"
 
+#include "GeckoProfiler.h"
 #include "DocAccessible-inl.h"
 #include "DocAccessibleChild.h"
 #include "nsEventShell.h"

Explicitly include GeckoProfiler.h to unbreak build on ppc64le and s390x platforms.
Seems the header is included indirectly on other platforms.

Assignee: nobody → dan
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

The severity field is not set for this bug.
:Jamie, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jteh)

The suggested change now landed as part of Bug 1680269.

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Flags: needinfo?(jteh)
Resolution: --- → DUPLICATE
Duplicate of bug: 1680269
You need to log in before you can comment on or make changes to this bug.