Closed Bug 1679405 Opened 2 years ago Closed 4 months ago

[Windows] System dialog opens after trying to save the file with “Save to PDF”

Categories

(Core :: Print Preview, defect)

Desktop
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox84 --- affected
firefox85 --- affected

People

(Reporter: mberlinger, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [print2020] [old-ui-])

Suggested Severity

  • S4

Affected versions

  • 85.0a1 (2020-11-26)
  • 84.0b4

Affected platforms

  • Windows 10x64

Preconditions

  • Perform a print via the “Save to PDF” destination in order to have the “Save to PDF” as the default set destination next time you use the print UI.
  • Have a printer configured via CUPS server.

Steps to reproduce

  1. Launch Firefox.
  2. Access the following webpage.
  3. Hit CTRL + P.
  4. Change the destination from “Save to PDF” to your actual printer.
  5. Set a custom range (ex: from 2 to 3)
  6. Change the destination back to “Save to PDF”
  7. Print the file.

Expected result

  • The file is successfully printed.

Actual result

  • After clicking the “Save” button from the “Save As” prompt, the old system dialog gets open. I’ve noted that before the system dialog gets open, an empty pdf file is generated and If you try to print with the newly open system dialog it will give you an error with the following error message being outputted inside the browser console: Uncaught (in promise) undefined.

Regression range

Additional notes

  • It is worth mentioning that I do not have access to the CUPS configured printer
QA Whiteboard: [qa-regression-triage]

Bob, can you reproduce?

Severity: -- → S3
Flags: needinfo?(bobowencode)

(In reply to Jonathan Kew (:jfkthame) from comment #1)

Bob, can you reproduce?

Sorry, got a bit swamped recently, no I can't reproduce this.
In the past this has been down to isInitializedFromPrinter (or maybe isInitializedFromPrefs) getting unset in the settings.

Flags: needinfo?(bobowencode)
QA Whiteboard: [qa-regression-triage]
Whiteboard: [print2020_v85] [old-ui-] → [print2020_v87] [old-ui-]

Maria, can you still reproduce this?

Flags: needinfo?(maria.berlinger)
Whiteboard: [print2020_v87] [old-ui-] → [print2020] [old-ui-]

Hello,
Sorry but I don’t have access anymore to the CUPS configured printer.

Flags: needinfo?(maria.berlinger)

Okay, thanks. Presumably this is fixed, otherwise we'd have had other reports of this by now.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.