Closed Bug 1679520 Opened 10 months ago Closed 8 months ago

Portrait mode will load only 1 or 2 pages in Print Preview, while landscape mode loads all the pages

Categories

(Core :: Print Preview, defect, P3)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- wontfix
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- wontfix

People

(Reporter: csasca, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression, testcase-wanted, Whiteboard: [print2020_v87] [old-ui+])

Affected versions

  • Firefox 84.0b5
  • Firefox 85.0a1

Affected platforms

  • Windows 7 & 10
  • macOS 11.1
  • Ubuntu 20.04

Steps to reproduce

  1. Launch Firefox
  2. Access this page
  3. Print preview the page and switch between Portrait and Landscape settings

Expected result

  • All the pages are rendered in Portrait mode

Actual result

  • Only 1 or 2 pages are loaded in Portrait mode

Regression range

  • I will see for a regression

Additional notes

  • The issue can be seen in the following attachment
  • The issue is reproducible on the old modal as well
  • See also 939897

Suggested severity

  • S3
Has Regression Range: --- → no
Has STR: --- → yes
Severity: -- → S3
Keywords: testcase-wanted
Priority: -- → P3
QA Whiteboard: [qa-regression-triage]

Hello! Attaching here the regression range made on Windows10x64:
Last good revision: bbc6744b3ca2f9b902c30bbb8c99965563421c5b
First bad revision: 18dbcec715c7f176ef13c30579efd5603148c4de
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bbc6744b3ca2f9b902c30bbb8c99965563421c5b&tochange=18dbcec715c7f176ef13c30579efd5603148c4de

Has Regression Range: no → yes
Regressed by: 1414600
Whiteboard: [print2020_v85] [old-ui+] → [print2020_v87] [old-ui+]

Chrome displays 2 pages in Print Preview too (in both Portrait and Landscape mode). So I suspect this a styling issue on the page that was exposed by fixing bug 1414600. Given that Chrome shows the same issue I'll assume this bug is invalid.

Please reopen if you can provide a reduced testcase that demonstrates a bug.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.