DNS: IP address do not refresh

RESOLVED DUPLICATE of bug 162871

Status

()

Core
Networking
RESOLVED DUPLICATE of bug 162871
16 years ago
16 years ago

People

(Reporter: Ian, Unassigned)

Tracking

({verifyme})

Trunk
x86
Windows 2000
verifyme
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

If the ip address of a site changes, due to the hosts file being changed on the
local system, the browser does not use the new ip address until the browser is
closed and restarted.

Reproducible: Always

Steps to Reproduce:
The steps below are using the following lines within the hosts file on a W2k System.

# This is mozilla ip address going to www.netscape.com
#207.200.81.215 www.netscape.com
# This is netscape ip address going to www.netscape.com
#64.12.180.19 www.netscape.com

1 - uncomment the line with ip 207.200.81.215 and save the hosts file.
2 - go to url http://www.netscape.com (you should get the mozilla web site)
3 - now comment the line with ip 207.200.81.215
4 - uncomment the line with ip 64.12.180.19 and save the host file.
5 - hit reload on the url going to http://www.netscape.com 

Actual Results:  
You will still get the mozilla web page even if the ip for www.netscape.com is
now pointing to the netscape site.

Expected Results:  
Expected that the cache would notice that the ip for the host has changed then
the cache would be void and it would reloaded from the new ip address.

1 - If I hit reload I would expect that the cache would be flushed. I beleive
the media cache(html/gif...) is flushed however the ip address/domain is still
cached.

2 - Even if I just continue browsing after step 5, it is still using the mozilla
ip address for netscape.com domain. Now If I had not hit the reload then maybe I
can see it still getting the ip from the cache.

3 - I can get it to work if I shutdown and restart the browser between step 2 and 5

4 - I checked this with other browsers - Netscape 4.8 and IE 6 SP1 and they
behave the same way.

5 - you are probably wondering why would the ip address ever change?
  - We are developping a site using load balancing techniques where www.site.com
can go to ip 1.1.1.1 and 1.1.1.2. 
  - For us to do testing, we would like to connect to the 1.1.1.1 ip and 1.1.1.2
to make sure it works however if we go to www.site.com we get 
    randomly thrown to one of these ip address. So we wanted to use the hosts
file to make sure that we go directly to a specified box. Now we have
    to restart our browser every time we want to go to another box.
This is not cache.. (and it's a dup).
Assignee: gordon → new-network-bugs
Component: Networking: Cache → Networking
QA Contact: tever → benc
Whiteboard: DUPEME
(Reporter)

Comment 2

16 years ago
What is the dup - I can't find it.

Comment 3

16 years ago
We have an DNS (hostname->IP) cache. The records are currently permanent.

I will dupe this when I have a chance to gather up all the bugs.
Summary: IP Cache not being flushed on reload → DNS: IP address do not refresh

Comment 4

16 years ago
Please verify if you agree. REOPEN if you do not.

*** This bug has been marked as a duplicate of 162871 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Keywords: verifyme
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.