Closed Bug 1679883 Opened 2 years ago Closed 2 years ago

Hide separators in mail window better

Categories

(SeaMonkey :: MailNews: Message Display, task)

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.82
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: iannbugzilla, Assigned: iannbugzilla)

References

Details

(Whiteboard: SM2.53.6)

Attachments

(1 file, 1 obsolete file)

Following on from Bug 1600103, the hiding of separators in the folder pane and message pane context menus needs to be done better.

Attached patch better hiding (obsolete) — Splinter Review

From what I can see on Linux, using a better hideIfAppropriate function means that checkLastSeparator is no longer needed or the checking for onLink. Hopefully that is the same on Windows and macOS. Requesting feedback.

Attachment #9190401 - Flags: feedback?(frgrahl)

Fixed comment and removed extra LF as mentioned on IRC.

[Approval Request Comment]
Regression caused by (bug #): 1600103
User impact if declined: extra separators
Testing completed (on m-c, etc.): 2.53.6
Risk to taking this patch (and alternatives if risky): none
String changes made by this patch: none

Attachment #9190401 - Attachment is obsolete: true
Attachment #9190401 - Flags: feedback?(frgrahl)
Attachment #9191509 - Flags: review?(frgrahl)
Attachment #9191509 - Flags: approval-comm-release?
Attachment #9191509 - Flags: approval-comm-esr60?

Comment on attachment 9191509 [details] [diff] [review]
better hiding v1.1

LGTM

  • hideIfAppropriate("folderPaneContext-sep-edit");
  • hideIfAppropriate("folderPaneContext-sep1");
  • hideIfAppropriate("folderPaneContext-sep4");

folderPaneContext-sep-edit comes after -sep1. Doesn't make a practial difference with the algorithm but shouldn't -sep1 be checked first?

r/a+ either way.

Attachment #9191509 - Flags: review?(frgrahl)
Attachment #9191509 - Flags: review+
Attachment #9191509 - Flags: approval-comm-release?
Attachment #9191509 - Flags: approval-comm-release+
Attachment #9191509 - Flags: approval-comm-esr60?
Attachment #9191509 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/ad79488515ed
Hide separators in mail window better. r=frg

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Whiteboard: SM2.53.6
Target Milestone: --- → seamonkey 2.82
You need to log in before you can comment on or make changes to this bug.