[PP]MultiTrigger: Triggering 3 or more jar files results in crash

VERIFIED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
P3
critical
VERIFIED WORKSFORME
19 years ago
2 years ago

People

(Reporter: Jimmy Lee, Assigned: Cathleen)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build 1999-10-18-09-M11(WIN), 1999-10-18-12-M11(MAC), 1999-10-18-08-M11(LINUX)

1. Load apprunner and open http://jimbob/jars/a_multitrigger.html

Script:
<html>
<!--
////////////////////////////////////////////////////////////////////////
// a_multitrigger
//
// Acceptance test
//      • Triggers four different jar files sequentially
//
// ~ XPInstall QA
//   July 15, 1999
//
////////////////////////////////////////////////////////////////////////
//-->
<h1> MultiTrigger Test </h1>
<hr>

<head>
<script>
allJars = {"Multitrigger--First":"http://jimbob/jars/a_multitrigger_first.jar",

"Multitrigger--Second":"http://jimbob/jars/a_multitrigger_second.jar",

"Multitrigger--Third":"http://jimbob/jars/a_multitrigger_third.jar",

"Multitrigger--Fourth":"http://jimbob/jars/a_multitrigger_fourth.jar"};

function notify(str, err)
   {
        document.write(str + "--" + err + "<br>");
   }

</script>
</head>
<body>
<script>
InstallTrigger.Install(allJars, notify);
</script>
</body>
</html>

RESULT:
Macintosh behaves as expected.  For Linux and Win98/NT, the first jar file is
triggered successfully followed by a crash.

EXPECTED RESULT:
No crash.  Four jar files are triggered.
(Reporter)

Comment 1

19 years ago
Talkback Incident ID 14374525

Stack Trace

nsDST::NodeArena::FreeNode
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsDST.cpp, line 195]
nsDST::Remove [d:\builds\seamonkey\mozilla\layout\html\base\src\nsDST.cpp, line
592]
FrameManager::SetPrimaryFrameFor
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsFrameManager.cpp, line 381]
DeletingFrameSubtree
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6733]
DeletingFrameSubtree
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6790]
DeletingFrameSubtree
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6790]
DeletingFrameSubtree
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 6790]
nsCSSFrameConstructor::ContentRemoved
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line
7001]
StyleSetImpl::ContentRemoved
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp, line 963]
PresShell::ContentRemoved
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 1854]
nsDocument::ContentRemoved
[d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp, line 1590]
nsHTMLDocument::ContentRemoved
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLDocument.cpp, line
1094]
nsDocument::Reset [d:\builds\seamonkey\mozilla\layout\base\src\nsDocument.cpp,
line 799]
nsHTMLDocument::Reset
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLDocument.cpp, line
323]
nsHTMLDocument::OpenCommon
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLDocument.cpp, line
1692]
nsHTMLDocument::Open
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLDocument.cpp, line
1782]
nsHTMLDocument::ScriptWriteCommon
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLDocument.cpp, line
1860]
nsHTMLDocument::Write
[d:\builds\seamonkey\mozilla\layout\html\document\src\nsHTMLDocument.cpp, line
1898]
NSHTMLDocumentWrite
[d:\builds\seamonkey\mozilla\dom\src\html\nsJSHTMLDocument.cpp, line 1168]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 673]
js_Interpret [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 2249]
js_Invoke [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 693]
js_InternalCall [d:\builds\seamonkey\mozilla\js\src\jsinterp.c, line 766]
JS_CallFunctionValue [d:\builds\seamonkey\mozilla\js\src\jsapi.c, line 2687]
handleTriggerEvent
[d:\builds\seamonkey\mozilla\xpinstall\src\nsXPITriggerInfo.cpp, line 123]
PL_HandleEvent [plevent.c, line 535]
PL_ProcessPendingEvents [plevent.c, line 494]
_md_EventReceiverProc [plevent.c, line 967]
USER32.dll + 0x1820 (0x77e71820)
nsAppShellService::Run
[d:\builds\seamonkey\mozilla\xpfe\appshell\src\nsAppShellService.cpp, line 468]
main1 [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 599]
main [d:\builds\seamonkey\mozilla\xpfe\bootstrap\nsAppRunner.cpp, line 710]
mainCRTStartup()
KERNEL32.dll + 0x1ba06 (0x77f1ba06)
(Assignee)

Comment 2

19 years ago
Jimmy, I used today's relase build and my debug build, but unable to see the
crash.

Can you try again with tomorrows build?
(Reporter)

Comment 3

19 years ago
Builds 1999-10-21-11-M11(WIN), 1999-10-22-08-M11(LINUX)

I cannot reproduce the problem with these builds.  Jars appears to install as
expected.  I wonder what could have changed to make this dramatic difference.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 4

19 years ago
well, don't know what happened, but it's working now.
marking bug WORKSFORME.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

19 years ago
Since this is a test case that is run fairly consistently, no specific
explanation is required.  Any new problems discovered will result in a new bug
report.  Marking Verified.

Comment 6

19 years ago
Bulk move of XPInstall (component to be deleted) bugs to Installer: XPInstall
Engine
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.