Closed Bug 1680279 Opened 3 years ago Closed 2 years ago

Allow "url" as property filter for tabs.onUpdated

Categories

(WebExtensions :: General, enhancement, P5)

Firefox 83
enhancement

Tracking

(firefox88 fixed)

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: robbendebiene, Assigned: robwu, Mentored)

Details

(Keywords: dev-doc-complete, good-first-bug)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

browser.tabs.onUpdated.addListener() supports filtering for specific properties such as "favIconUrl", "status" or "title".

browser.tabs.onUpdated.addListener(handleUpdated, {
  properties: ["url"]
});

Actual results:

"url" is not allowed as a property filter even if the tabs permission is granted.

Expected results:

I cannot think of any reason why "url" shouldn't be allowed as a property filter.

Are you interested in submitting a patch once you're done with bug 1679688? I expect this one to be much easier.

Mentor: rob
Severity: -- → N/A
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: good-first-bug
Priority: -- → P5

Yeah, I already thought about it. I just wanted to wait if this behaviour was by design.

Hi I would like to work on this bug as my first contribution. It would be really great if you could mentor me on what all I need to setup to start working on this issue.

The patch for bug 1498432 will include a unit test that uses
tabs.onUpdated with the "url" filter for "properties".

The updated test here verifies that the tabs.onUpdated event does not
include other properties in changeInfo when filtering by "status".

Assignee: nobody → rob
Status: NEW → ASSIGNED
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/4c8c60ac262a
Support "url" properties in filter r=rpl

Backed out 2 changesets (bug 1498432, bug 1680279) for causing bc failures in browser_ext_tabs_discard_reversed.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/ab3f023535ea70eaa8dd35b3c4833db2a7fa480e
Push with failures, failure log.

Flags: needinfo?(rob)
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/c412a138722e
Support "url" properties in filter r=rpl
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Flags: needinfo?(rob)
You need to log in before you can comment on or make changes to this bug.