Closed Bug 1680471 Opened 2 years ago Closed 2 months ago

Double titlebar on Ubuntu Linux in GNOME Shell

Categories

(Core :: Widget: Gtk, defect, P2)

Firefox 83
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: stu.axon, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0

Steps to reproduce:

With "titlebar" unticked I get two sets of Window controls in GNOME shell.

Screenshot attached.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

U see, which ubuntu do you run? Is that plain gnome or something else?

Blocks: gtktitlebar
Flags: needinfo?(stu.axon)
Priority: -- → P2

Can you attach output of 'env | grep XDG' terminal command?
Thanks.

Hi,
It's plain GNOME on Ubuntu 20.04, but probably not the default theme. I have tried disabling all GNOME extensions and seen the same thing (though that was not this screenshot).

env | grep XDG    stu@computer  6004  16:30:07 
XDG_SESSION_TYPE=x11
XDG_RUNTIME_DIR=/run/user/1000
XDG_SESSION_DESKTOP=ubuntu
XDG_DATA_DIRS=/home/stu/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share/:/usr/share/ubuntu:/home/stu/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share/:/usr/share/:/var/lib/snapd/desktop
XDG_CURRENT_DESKTOP=ubuntu:GNOME
XDG_CONFIG_DIRS=/etc/xdg/xdg-ubuntu:/etc/xdg
XDG_SESSION_CLASS=user
XDG_MENU_PREFIX=gnome-

Cheers
S

Flags: needinfo?(stu.axon)

Which Firefox version is that? Default ubuntu installation (is that a snap?) or flatpak or something else?
Thanks.

Flags: needinfo?(stu.axon)

Cheers, it looks like the default ubuntu deb (I checked no snaps or flatpaks with 'moz' or 'firefox' in the name are installed)

$ dpkg -s firefox
Package: firefox
Status: install ok installed
Priority: optional
Section: web
Installed-Size: 211986
Maintainer: Ubuntu Mozilla Team <ubuntu-mozillateam@lists.ubuntu.com>
Architecture: amd64
Version: 83.0+build2-0ubuntu0.20.04.1
Replaces: kubuntu-firefox-installer
Provides: gnome-www-browser, iceweasel, www-browser
Depends: lsb-release, libatk1.0-0 (>= 1.12.4), libc6 (>= 2.30), libcairo-gobject2 (>= 1.10.0), libcairo2 (>= 1.10.0), libdbus-1-3 (>= 1.9.14), libdbus-glib-1-2 (>= 0.78), libfontconfig1 (>= 2.12.6), libfreetype6 (>= 2.10.1), libgcc-s1 (>= 3.3), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.37.3), libgtk-3-0 (>= 3.4), libharfbuzz0b (>= 0.6.0), libpango-1.0-0 (>= 1.14.0), libpangocairo-1.0-0 (>= 1.14.0), libpangoft2-1.0-0 (>= 1.14.0), libstdc++6 (>= 9), libx11-6, libx11-xcb1 (>= 2:1.6.9), libxcb-shm0, libxcb1, libxcomposite1 (>= 1:0.4.5), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6, libxrender1, libxt6
Recommends: xul-ext-ubufox, libcanberra0, libdbusmenu-glib4, libdbusmenu-gtk3-4
Suggests: fonts-lyx
Conffiles:
/etc/apparmor.d/usr.bin.firefox 8ca78523c18a151a7ed7488223bcffa0
/etc/apport/blacklist.d/firefox ee63264f847e671832d42255912ce144
/etc/apport/native-origins.d/firefox 7c26b75c7c2b715c89cc6d85338252a4
/etc/firefox/syspref.js 09e457e65435a1a043521f2bd19cd2a1
Description: Safe and easy web browser from Mozilla
Firefox delivers safe, easy web browsing. A familiar user interface,
enhanced security features including protection from online identity theft,
and integrated search let you get the most out of the web.
Xul-Appid: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}

$ dpkg -S $(which firefox)
firefox: /usr/bin/firefox

Flags: needinfo?(stu.axon)

If only Ubuntu's packages created by Ubuntu are affected, then this should be reported to Ubuntu at Ubuntu's issue tracker.
Hence it would be good to try an upstream package.

Can you please try a binary from mozilla? How-to is here:
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems?rd=Bug_info_Firefox#Testing_Mozilla_binaries

Also is that a regression? Did that worked before?

Also please try to debug Firefox titlebar state as described here:
https://fedoraproject.org/wiki/How_to_debug_Firefox_problems#Testing_Firefox_titlebar

Thanks.

Flags: needinfo?(stu.axon)

Is this because CSD is disabled? Could you try going to Customize and unchecking Title Bar?

CSD works in other apps, such as Gedit, Nautilus and Tilix.

Downloading firefox from the link and running it helped narrow things down.

Using the default Adwaita theme and running like this worked:
MOZ_GTK_TITLEBAR_DECORATION=client ./firefox -ProfileManager -no-remote

I was also able to reproduce that on my installed firefox.

I updated the Numix theme I was using and this now works the same as Adwaita (e.g. only when MOZ_GTK_TITLEBAR_DECORATION=client is set).

I updated my firefox desktop file with Menulibre, so that things work in the meantime:

env MOZ_GTK_TITLEBAR_DECORATION=client firefox %u

Without the environment variable things still don't work as expected, I'm going to attach two screenshots of the default Adwaita theme, with titlebar checked and unchecked respectively.

Flags: needinfo?(stu.axon)

The screenshots show the bug reproduced with firefox downloaded from the .tar.bz from the link above, without MOZ_GTK_TITLEBAR_DECORATION set.

I just did clean Ubuntu 20.04 installation, install all updates, restart the box and launch default Firefox, disabled system titlebar (it's on by default) and it looks as expected, i.e. no double titlebar here. So I wonder what can be wrong in your installation.

Thanks for going to that effort. My box has been upgraded from previous versions and has been my dev + home laptop for the last 3 years, so there is probably all sorts of stuff on it.

I guess if I want to debug this further I should try and do a similar thing and try a fresh Ubuntu in a VM + try installing things / setting it up until I manage to break it in the same way.

Flags: needinfo?(stu.axon)

Redirect a needinfo that is pending on an inactive user to the triage owner.
:stransky, since the bug has high priority, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(stu.axon) → needinfo?(stransky)
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Flags: needinfo?(stransky)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.