Cursor (caret) partly blinks over the last letter

VERIFIED DUPLICATE of bug 98564

Status

()

Core
Editor
VERIFIED DUPLICATE of bug 98564
16 years ago
16 years ago

People

(Reporter: Roger M. Wilcox, Assigned: kinmoz)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.1) Gecko/20020823 Netscape/7.0

When typing in the Mail Compose window, the typing cursor (i.e. the caret) is 
not all the way to the right of the last letter being typed.  In fact, it 
blinks about half-way in the middle of the last letter.  This is particularly 
apparent with a lowercase "f" typed in the Times font.


Reproducible: Always

Steps to Reproduce:
1. Launch Netscape 7 mailer.
2. Open a Compose window (e.g. by clicking on the Compose button in the 
toolbar.)
3. Click in the big message body area and type "ffffff" (in lower case but 
without the quotes).  Notice that the vertical-bar typing cursor (technically 
called the "caret") looks to be about in the middle of the last "f".
4. Press Enter to go to a new line.
5. Press Backspace to erase the hard-return you just inserted.  Notice that the 
cursor is now a couple of pixels farther to the right of the last "f" than it 
was in step 3.
6. Press the left arrow key, then the right arrow key.  The cursor is now in 
the middle of the last "f" again.
7. Press the down arrow key.  The cursor jumps a couple of pixels to the right.

Actual Results:  
The cursor appears in the middle of the last letter while typing, but to the 
right of the last letter if you've hit return and then hit backspace.

Expected Results:  
The cursor should appear to the right of the last letter while typing, whether 
or not you've just hit return-and-backspace.

We are using an embedded Gecko editor in our product and are seeing the same 
behavior there.  Having a Gecko fix for this ASAP would help our product, too.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Hardware: PC → All
Summary: Cursor (caret) partly blinks over the last letter in Mail Compose → Cursor (caret) partly blinks over the last letter
Whiteboard: DUPEME

Comment 1

16 years ago
This is a dup of an old bug we have.

*** This bug has been marked as a duplicate of 98564 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
verified dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.