Closed Bug 1680885 Opened 2 years ago Closed 7 months ago

Add a menu "Move PiP Toggle to Left(Right)" in context menu for the PiP toggle button

Categories

(Toolkit :: Video/Audio Controls, enhancement)

Desktop
Windows 10
enhancement

Tracking

()

VERIFIED FIXED
95 Branch
Tracking Status
relnote-firefox --- 95+
firefox85 --- wontfix
firefox95 + verified

People

(Reporter: alice0775, Assigned: rhopkinsdev)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Keywords: nightly-community)

Attachments

(2 files)

Attached image image.png

"Hide Picture-in-Picture Toggle" is provided.
I think it would be more convenient if there was "Move PiP Toggle to Left(Right)" menu.

Steps to reproduce:

  1. Open a Video
  2. Right click on the PiP toggle button

Expected Results:
The context menu is
"Hide Picture-in-Picture Toggle"
"Move PiP Toggle to Left(Right)"

Blocks: videopip
Assignee: nobody → rhopkinsdev
Status: NEW → ASSIGNED
Attachment #9246047 - Attachment description: WIP: Bug 1680885 - Add menu item in Picture-in-Picture toggle context menu to move the toggle to the opposite side of the video. → WIP: Bug 1680885 - Add menu item in Picture-in-Picture toggle context menu to move the toggle to the opposite side of the video. r=mhowell,mtigley
Attachment #9246047 - Attachment description: WIP: Bug 1680885 - Add menu item in Picture-in-Picture toggle context menu to move the toggle to the opposite side of the video. r=mhowell,mtigley → Bug 1680885 - Add menu item in Picture-in-Picture toggle context menu to move the toggle to the opposite side of the video. r=mtigley
Pushed by mtigley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c97b17652863
Add menu item in Picture-in-Picture toggle context menu to move the toggle to the opposite side of the video. r=mtigley,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 95 Branch

Micah, is that something we should mention in our release notes? Thanks

Flags: needinfo?(mtigley)

(In reply to Pascal Chevrel:pascalc from comment #4)

Micah, is that something we should mention in our release notes? Thanks

Yes! This would be a good addition to our release notes.

Flags: needinfo?(mtigley)

Could you request it through Bugzilla so as that we don't forget about it? Thanks
https://wiki.mozilla.org/Release_Management/Release_Notes#Nomination_in_Bugzilla

Flags: needinfo?(tigleym)

[Tracking Requested - why for this release]:
This change adds a new menu item to the Picture-in-Picture toggle button's context menu: "Move Picture-in-Picture Toggle to Left/Right Side". By default, the toggle button is positioned at the right side of a video element but this menu item will allow users to move it to the left side, and vice versa. This was added to allow direct user configuration of the button's positioning.

Flags: needinfo?(tigleym)

Release Note Request (optional, but appreciated)
This change adds a new menu item to the Picture-in-Picture toggle button's context menu: "Move Picture-in-Picture Toggle to Left/Right Side". By default, the toggle button is positioned at the right side of a video element but this menu item will allow users to move it to the left side, and vice versa. This was added to allow direct user configuration of the button's positioning.

Doesn't affect Firefox for Android.

relnote-firefox: --- → ?

Added to Firefox 95 beta release notes with this wording:

The Picture-in-Picture toggle button can now be moved to the opposite side of the video from the new context menu option Move Picture-in-Picture Toggle to Left (Right) Side.

QA verified this implementation (including some exploratory testing) as part of the Beta 95 regression testing 1/3 round, platforms covered: Windows 10, Windows 7, macOS 11.0 and Ubuntu 20.
A spotcheck was performed on Nightly 96 as well, platforms covered: Windows 10, macOS 11.0 ARM , Ubuntu 21.
Our testing revealed no new issue.

Status: RESOLVED → VERIFIED
Duplicate of this bug: 1550453
You need to log in before you can comment on or make changes to this bug.