Closed Bug 1680901 Opened 10 months ago Closed 10 months ago

Perma central-as-beta /html/webappapis/dynamic-markup-insertion/document-write/module-tla-delayed.html | and other files | document.write in an imported module - Test timed out | expected OK when Gecko 85 merges to Beta on 2020-12-14

Categories

(Core :: DOM: Core & HTML, defect, P2)

defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- unaffected
firefox85 + verified

People

(Reporter: bogdan_tara, Assigned: ystartsev)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Central as beta simulation.
https://treeherder.mozilla.org/jobs?repo=try&group_state=expanded&revision=e97e84bc01abddc9a0ec37bdc57f3ee2cea06a5d&test_paths=%2Fhtml%2Fwebappapis%2F&selectedTaskRun=eE-dsi14QjCTsMm2PsHSVg.0

Failure log: https://treeherder.mozilla.org/logviewer?job_id=323657413&repo=try&lineNumber=19046

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/Jghn-dzzR22pPzKtu2PLWQ/runs/0/artifacts/public/logs/live_backing.log

[task 2020-12-05T12:38:47.671Z] 12:38:47     INFO - TEST-START | /html/webappapis/dynamic-markup-insertion/document-write/module-tla-delayed.html
[task 2020-12-05T12:38:47.739Z] 12:38:47     INFO - Setting pref javascript.options.experimental.top_level_await (true)
[task 2020-12-05T12:38:47.796Z] 12:38:47     INFO - Closing window 176
[task 2020-12-05T12:38:47.820Z] 12:38:47     INFO - PID 15966 | [Child 16348, Main Thread] WARNING: Extra shutdown CC: 'i < NORMAL_SHUTDOWN_COLLECTIONS', file /builds/worker/checkouts/gecko/xpcom/base/nsCycleCollector.cpp:3360
[task 2020-12-05T12:38:47.821Z] 12:38:47     INFO - PID 15966 | [Child 16348, Main Thread] WARNING: NS_ENSURE_TRUE(Preferences::InitStaticMembers()) failed: file /builds/worker/checkouts/gecko/modules/libpref/Preferences.cpp:4339
[task 2020-12-05T12:38:48.218Z] 12:38:48     INFO - PID 15966 | [Parent 15966, IPDL Background] WARNING: Cannot record shutdown step, mConnection is nullptr: file /builds/worker/checkouts/gecko/dom/localstorage/ActorsParent.cpp:8027
[task 2020-12-05T12:38:48.314Z] 12:38:48     INFO - PID 15966 | [Parent 15966, IPDL Background] WARNING: Cannot record shutdown step, mConnection is nullptr: file /builds/worker/checkouts/gecko/dom/localstorage/ActorsParent.cpp:8027
[task 2020-12-05T12:38:48.322Z] 12:38:48     INFO - PID 15966 | JavaScript error: http://web-platform.test:8000/html/webappapis/dynamic-markup-insertion/document-write/module-tla-delayed-iframe.html, line 12: SyntaxError: top level await is not currently supported
[task 2020-12-05T12:39:18.319Z] 12:39:18     INFO - 
[task 2020-12-05T12:39:18.319Z] 12:39:18     INFO - TEST-UNEXPECTED-TIMEOUT | /html/webappapis/dynamic-markup-insertion/document-write/module-tla-delayed.html | document.write in an imported module - Test timed out
[task 2020-12-05T12:39:18.320Z] 12:39:18     INFO - TEST-UNEXPECTED-TIMEOUT | /html/webappapis/dynamic-markup-insertion/document-write/module-tla-delayed.html | expected OK
[task 2020-12-05T12:39:18.320Z] 12:39:18     INFO - TEST-INFO took 30650ms
Flags: needinfo?(ystartsev)

Looks like this is failing because the flag for TLA is only valid in nightly. I updated the tests to have the old behavior on release and beta.

Flags: needinfo?(ystartsev)
Assignee: nobody → ystartsev
Severity: -- → S3
Status: NEW → ASSIGNED
Priority: -- → P2
Pushed by ystartsev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2d8408091f2a
Fix Top-level await tests so they do not try to run the nightly-only flag dependant tests on beta or release r=jonco

For the exit result of the test, OK needs to be used instead of PASS. If OK or PASS is the only default result without a condition defined, it doesn't need to be mentioned.

Pushed by ystartsev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f3dd454ac497
Fix Top-level await tests so they do not try to run the nightly-only flag dependant tests on beta or release r=jonco
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
You need to log in before you can comment on or make changes to this bug.