Closed Bug 1680916 Opened 10 months ago Closed 10 months ago

Windows 32-bit facebook.com Crash in [@ OOM | large | mozalloc_abort | alloc::raw_vec::RawVec<T>::allocate_in<T>]

Categories

(Core :: Graphics: WebRender, defect)

x86
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1531819

People

(Reporter: aryx, Unassigned)

Details

(Keywords: crash)

Crash Data

32-bit only crash new in 84.0 betas (starting with beta 1). Windows 10 is also affected and sees the majority of crashes.

Most of the crashes hit when the user has https://www.facebook.com open (based on the reports where the person submitted the url).

Matt, please evaluate what should be done for Firefox 84 here (this week the release candidates are being built).

Crash report: https://crash-stats.mozilla.org/report/index/f6112776-4882-424f-a67e-82f670201130

MOZ_CRASH Reason: MOZ_CRASH()

Top 10 frames of crashing thread:

0 mozglue.dll mozalloc_abort memory/mozalloc/mozalloc_abort.cpp:33
1 mozglue.dll mozalloc_handle_oom memory/mozalloc/mozalloc_oom.cpp:51
2 xul.dll gkrust_shared::oom_hook::hook toolkit/library/rust/shared/lib.rs:132
3 xul.dll std::alloc::rust_oom ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39//library/std/src/alloc.rs:309
4 xul.dll alloc::alloc::handle_alloc_error ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39//library/alloc/src/alloc.rs:322
5 xul.dll static alloc::raw_vec::RawVec<bool, alloc::alloc::Global>::allocate_in<bool, alloc::alloc::Global> ../18bf6b4f01a6feaf7259ba7cdae58031af1b7b39/library/alloc/src/raw_vec.rs:191
6 xul.dll static webrender_api::display_list::DisplayListBuilder::with_capacity gfx/wr/webrender_api/src/display_list.rs:997
7 xul.dll webrender_bindings::bindings::wr_state_new gfx/webrender_bindings/src/bindings.rs:2348
8 xul.dll mozilla::wr::DisplayListBuilder::DisplayListBuilder gfx/webrender_bindings/WebRenderAPI.cpp:931
9 xul.dll mozilla::layers::WebRenderLayerManager::EndTransactionWithoutLayer gfx/layers/wr/WebRenderLayerManager.cpp:322
Flags: needinfo?(matt.woodrow)

Probably too late to address in 84, but let's keep an eye on it in case it spikes on release.

Blocks: gfx-triage
Flags: needinfo?(matt.woodrow)

Is this perhaps just a signature change?

I think this is probably the same as bug 1531819

Sure looks like it, thanks for checking.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1531819
No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.