[DOGFOOD] IME bug-Return key deletes the characters

VERIFIED FIXED in M11

Status

()

Core
Internationalization
P1
major
VERIFIED FIXED
19 years ago
8 years ago

People

(Reporter: Teruko Kobayashi, Assigned: Frank Tang)

Tracking

({inputmethod})

Trunk
x86
Windows NT
inputmethod
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
When you type Japanese characters by using IME and hit the Return key to
go to next line, the characters you typed in the previous line will be deleted.

Steps of reproduce
1. Open the HTML Editor by selecting menu Tasks|Editor
2. Turn on IME by Alt+~
3. Type some Japanese characters in the first line and commit the characters
4. Hit the return key

The Japanese characters you typed in step3 will be deleted.
Sometimes when you type in the first line of the Editor, you cannot reproduce
this.  However, from second line of the Editor, this is reproduciable.

Tested 10-19-08 Win32 build.

Updated

19 years ago
Blocks: 16127
Summary: IME bug-Return key deletes the characters → IME bug-Return key deletes the characters

Comment 1

19 years ago
Adding dependency

Updated

19 years ago
Summary: IME bug-Return key deletes the characters → [DOGFOOD] IME bug-Return key deletes the characters
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Priority: P3 → P1
Target Milestone: M11
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 2

19 years ago
find the problem
The problem is we insert 0 character in the nsHTMLEditor . Which later got treat
as end of string in the html rule code.

Kathy review my change. I check in the fix today.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

19 years ago
I verified this in 10-28-08 Win32 build.
Keywords: inputmethod
You need to log in before you can comment on or make changes to this bug.