Closed Bug 1681214 Opened 1 year ago Closed 1 year ago

Users' print-dialog margin choices aren't respected, if the content uses "@page { margin: ... }"

Categories

(Core :: Printing: Output, task)

task

Tracking

()

RESOLVED DUPLICATE of bug 1661663

People

(Reporter: dholbert, Unassigned)

Details

(Keywords: parity-chrome, Whiteboard: [print2020])

Attachments

(1 file)

STR:

  1. Load attached testcase.
  2. Ctrl+P to open print dialog (with print.tab_modal.enabled set to true, as it is in Nightly)
  3. Open "More Settings"
  4. Try the various options under "Margins" (Default vs. Minimum vs. None vs. Custom) and see how they affect the preview rendering.

ACTUAL RESULTS:
The user's choice seems to be disregarded entirely. The rendering always uses 1.5in margins, regardless of the user's choice.

EXPECTED RESULTS:
If the user chooses "Default", we should honor the page's provided 1.5in page-margins.
Otherwise, if the user chooses "Minimal" or "None" or "Custom", we should honor what the user requested, and override the @page margin.

The "expected results" here are "expected" from the perspective of "respect the user's choices over the author's choices, where presentation is concerned", as well as from a webcompat perspective (Chrome gives EXPECTED RESULTS).

Whiteboard: [print2020]
Keywords: parity-chrome
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1661663
You need to log in before you can comment on or make changes to this bug.