Closed Bug 1681796 Opened 10 months ago Closed 8 months ago

Prevent superfluous PictureInPictureParent actors from being associated with each tab

Categories

(Firefox :: Untriaged, defect)

Firefox 85
defect

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox86 --- fixed

People

(Reporter: whjones526, Assigned: whjones526, NeedInfo)

References

(Blocks 3 open bugs)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:83.0) Gecko/20100101 Firefox/83.0

Assignee: nobody → whjones526

So I think this is due to the code at https://searchfox.org/mozilla-central/rev/4415bec7a49c50a338167d9c8934527b9cae59d0/toolkit/components/pictureinpicture/PictureInPicture.jsm#323-325 which will get the parent actor when handling a request to enter PiP.

This is odd because AFAICT we only use the ref for a check for where to position things (via a map) -- but it's not the right actor for that anyway, as it doesn't correspond to the player window. But it's quite possible I'm misunderstanding that part...

(In reply to :Gijs (he/him) from comment #1)

So I think this is due to the code at https://searchfox.org/mozilla-central/rev/4415bec7a49c50a338167d9c8934527b9cae59d0/toolkit/components/pictureinpicture/PictureInPicture.jsm#323-325 which will get the parent actor when handling a request to enter PiP.

This is odd because AFAICT we only use the ref for a check for where to position things (via a map) -- but it's not the right actor for that anyway, as it doesn't correspond to the player window. But it's quite possible I'm misunderstanding that part...

This is correct, I erroneously added this in a previous patch to keep the code as similar as possible to what it already was. I plan to remove this now.

Hi Hunter,

As per your last comment I see that the issue has been solved. For this reason I'll mark this ticket as Resolved - Works for me.

If the issue is still reproducible with the latest Firefox version, feel free to reopen the bug with more information.

Regards,
Virginia

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME

I think Hunter was referring to a line of code that had been added in a previous patch (one in bug 1589680). I think this bug is still valid - I'm going to re-open.

Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---

Hey Hunter, there's a small nit left on the patch that we hope can be addressed before it lands. Got time for it?

Flags: needinfo?(whjones526)
Blocks: 1685549
No longer blocks: 1662870
Blocks: 1680796
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/f7fd3b38dfff
Prevent superfluous PictureInPictureParent actors from being associated with each tab r=Gijs
Status: REOPENED → RESOLVED
Closed: 9 months ago8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
You need to log in before you can comment on or make changes to this bug.