Last Comment Bug 168186 - "max_cached_connections" pref doesn't stick
: "max_cached_connections" pref doesn't stick
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Networking (show other bugs)
: Trunk
: x86 Windows 2000
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://lxr.mozilla.org/mozilla/source...
: 365318 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-12 05:56 PDT by Henrik Gemal
Modified: 2009-11-08 14:02 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Henrik Gemal 2002-09-12 05:56:45 PDT
if you set the "max_cached_connections" pref to 1 the pref gets reset to 2 the 
next time your start mozilla mail.

I manually changed the pref in prefs.js so that I had:
user_pref("mail.server.server1.max_cached_connections", 1);

I then started mozilla and exited mozilla. No I had:
user_pref("mail.server.server1.max_cached_connections", 2);

the setting of the pref dont seem to stick.

is this on purpose? and why?

20020911
Comment 1 Henrik Gemal 2002-09-12 06:11:32 PDT
setting it to 1 via the UI (Server Settings -> Advanced) doesn't work either.
Perhaps we should alert people trying to set it to 1 if that's invalid. 
Accepting user input and then changing it is bad...:)
Comment 2 Henrik Gemal 2003-06-26 02:40:35 PDT
else if (maxConnections < 2)
{
  // forced to use at least 2
  maxConnections = 2;
  rv = SetMaximumConnectionsNumber(maxConnections);
}

perhaps this should be reflected in the UI? Should we just make into a dropdown box with 2 - 5
Comment 3 Gary Kwong [:gkw] [:nth10sd] 2008-05-01 12:55:22 PDT
*** Bug 365318 has been marked as a duplicate of this bug. ***
Comment 4 Gary Kwong [:gkw] [:nth10sd] 2008-05-01 12:56:06 PDT
IMAP issue, cc'ing Emre.
Comment 5 :Hb 2009-11-08 14:02:20 PST
FIXED by bienvenu 2004-03-09 17:00 to at least 1 connection.

Note You need to log in before you can comment on or make changes to this bug.