Closed Bug 1682593 Opened 3 months ago Closed 2 months ago

Remove the SSB feature

Categories

(Firefox :: General, task)

task

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox86 --- fixed

People

(Reporter: mossop, Assigned: mossop)

References

Details

Attachments

(1 file)

The SSB feature has only ever been available through a hidden pref and has multiple known bugs. Additionally user research found little to no perceived user benefit to the feature and so there is no intent to continue development on it at this time. As the feature is costing us time in terms of bug triage and keeping it around is sending the wrong signal that this is a supported feature we are going to remove the feature from Firefox.

Severity: -- → S4

What user research?
Fake-apps / PWAs / whatever names it comes in other browsers is quite a blocking missing feature in firefox for many.
Instead of polishing it a bit, you're removing it completely?
How about sending the right signal and put in couple hours work and couple days in testing adopting the fullscreen api for this purpose,
as to not costing us time in terms of bug triage and keeping it around?
Something along the lines of adding support for opening a link in fullscreen mode, with the twist offered by full-screen-api.ignore-widgets
Maybe even add some # to the link in saved .url to signal request to open in such mode automatically
Catch my drift?

(In reply to Mos At from comment #1)

How about sending the right signal and put in couple hours work and couple days in testing adopting the fullscreen api for this purpose,
as to not costing us time in terms of bug triage and keeping it around?
Something along the lines of adding support for opening a link in fullscreen mode, with the twist offered by full-screen-api.ignore-widgets
Maybe even add some # to the link in saved .url to signal request to open in such mode automatically
Catch my drift?

This sounds like a different feature really and should probably be filed as such. The work that will be removed here likely wouldn't help much with the implementation of that.

I don't know about this user research, but if I can give my humble opinion as a user, this feature is far from "no perceived user benefit". As it's implemented now it is pretty much useless, but it's because is totally incomplete, not because the feature would not be well received.

(In reply to Dave Townsend [:mossop] from comment #2)

(In reply to Mos At from comment #1)

How about sending the right signal and put in couple hours work and couple days in testing adopting the fullscreen api for this purpose,
as to not costing us time in terms of bug triage and keeping it around?
Something along the lines of adding support for opening a link in fullscreen mode, with the twist offered by full-screen-api.ignore-widgets
Maybe even add some # to the link in saved .url to signal request to open in such mode automatically
Catch my drift?

This sounds like a different feature really and should probably be filed as such. The work that will be removed here likely wouldn't help much with the implementation of that.

But removing the work here now, makes any implementation of that alternative later highly unlikely.
There's quite a difference between we have this SSB alpha thing, it's lame but you can use it for now and the categorical we have nothing.

I personally doubt this is easing dev life significantly, but even if it does, I would humbly suggest to drop it until something can be offered in return, because the perception of removing it costs more.

(In reply to Mos At from comment #4)

(In reply to Dave Townsend [:mossop] from comment #2)

(In reply to Mos At from comment #1)

How about sending the right signal and put in couple hours work and couple days in testing adopting the fullscreen api for this purpose,
as to not costing us time in terms of bug triage and keeping it around?
Something along the lines of adding support for opening a link in fullscreen mode, with the twist offered by full-screen-api.ignore-widgets
Maybe even add some # to the link in saved .url to signal request to open in such mode automatically
Catch my drift?

This sounds like a different feature really and should probably be filed as such. The work that will be removed here likely wouldn't help much with the implementation of that.

But removing the work here now, makes any implementation of that alternative later highly unlikely.

I don't think that follows but then I also think that the reasons for not continuing work here also apply to this alternative.

There's quite a difference between we have this SSB alpha thing, it's lame but you can use it for now and the categorical we have nothing.

Yes, it encourages folks to use it when we know it is buggy and we have no plans to maintain/improve it. If the feature was working reasonably well there would likely be a different trade-off here but there is a reason that this feature is effectively hidden from users.

I personally doubt this is easing dev life significantly, but even if it does, I would humbly suggest to drop it until something can be offered in return, because the perception of removing it costs more.

Currently not significantly, but spending any time at all on a feature that we have no intention to develop further means time lost to other projects. As it is the feature is living on borrowed time and will break when some upcoming platform changes land. Fixing it to support those changes would be a significant investment.

Thank you for the detailed response.
The big numbers telemetry game often fails to catch the subtility of some changes and how it affects the core as well as the swinging user base.
I was intrigued by the "user research" that managed to miss all the people I know using it and/or planning on using it if it were improved.
After Containers became main stream, I honestly thought SSB is gonna get some attention as it simply clicks together in my mind.
If there's no intention left, fine, sorry to waste your time. Just had to add my 3.79 cents.

Was this not the path forward for Firefox on full PWA support?

If it was:
Is there an alternate plan now?

If it wasn't:
Does Firefox have any intention of PWA support?

(In reply to leebickmtu from comment #7)

Was this not the path forward for Firefox on full PWA support?

If it was:
Is there an alternate plan now?

If it wasn't:
Does Firefox have any intention of PWA support?

It was, there is currently no plan for PWA support in Firefox.

I would also be interested in the methodology and research of the user research that was conducted.

sorry, meant to say "results of"

I disagree, many people have been waiting for PWA support in Firefox. Removing this feature, may result in people (including me, a huge Firefox advocate) switching from Firefox, to a browser that supports PWA. I'm very disappointed.

I also would like to see the results of the research, Dave was talking about.

we are going to remove the feature from Firefox.

You should reconsider this decision. It is understandable that currently there might not be enough resources to finish full PWA support, like in competing browsers, but removing it completely will not only make all work done on it a waste of time, but also send wrong signal to some users.
Leaving feature hidden under flag for enthusiasts to experiment on and, maybe, even submit patches that will nudge it closer to completion - that would be a bigger win, than removing feature altogether.

With popular game streaming apps on iOS moving to web, PWAs will become even more important than ever, as more users will learn that one can add a "website" to their homescreen on the phone and even on desktop computer. Consider business use cases too, when instead of installing Electron apps system administrator could just allow installing popular apps as PWA on work devices.

I'm still patiently waiting for a day when I will be able to add some regularly used web apps to my desktop and use them as any other program on my computer without any additional installs.

(In reply to Hexandcube from comment #12)

I disagree, many people have been waiting for PWA support in Firefox. Removing this feature, may result in people (including me, a huge Firefox advocate) switching from Firefox, to a browser that supports PWA. I'm very disappointed.

We already don't have the feature working in any decent fashion so I'm not sure removing it will have any impact here.

I also would like to see the results of the research, Dave was talking about.

Unfortunately I think that the research is confidential at the moment.

(In reply to joshas from comment #13)

You should reconsider this decision. It is understandable that currently there might not be enough resources to finish full PWA support, like in competing browsers, but removing it completely will not only make all work done on it a waste of time, but also send wrong signal to some users.
Leaving feature hidden under flag for enthusiasts to experiment on and, maybe, even submit patches that will nudge it closer to completion - that would be a bigger win, than removing feature altogether.

The signal I hope we are sending is that PWA support is not coming to desktop Firefox anytime soon. At this point I don't think we would accept patches to improve the feature so I don't think leaving the code in Firefox makes any sort of sense. Speaking as the developer who spent a good deal of time writing most of the code I am frustrated to see it removed too, but it is the decision that makes sense at this time.

Additionally user research found little to no perceived user benefit to the feature

Meaning little to no benefit of the buggy incomplete implementation?

(In reply to Thayne from comment #17)

Additionally user research found little to no perceived user benefit to the feature

Meaning little to no benefit of the buggy incomplete implementation?

No the user research was not performed on the implementation in Firefox.

(In reply to Dave Townsend [:mossop] from comment #15)

The signal I hope we are sending is that PWA support is not coming to desktop Firefox anytime soon. At this point I don't think we would accept patches to improve the feature so I don't think leaving the code in Firefox makes any sort of sense. Speaking as the developer who spent a good deal of time writing most of the code I am frustrated to see it removed too, but it is the decision that makes sense at this time.

This is very sad! PWA is future of agile apps development. Please let's consider this decision again. Is there something what the community can do?

As I'm using Microsoft Outlook on Mac and Linux using Edge (Chrome)'s PWA feature I've been actively tracking Firefox's implementation. The convenience of not having to hunt down and launch Electron apps, and using the desktop shell to interact with web apps made PWA's on the desktop (Especially on alternative OS'es) a blessing.

Removing this from Firefox (or stopping finishing a proper implementation including Dock / Panel icons and proper menu bar) will require me to keep Chrome/Edge around for this purpose. Which I would see as another nail in FF's coffin tbh...

Great, the moment I discover a feature I needed is when it's being removed 😅
Do you know if this will affect work on #1283670, the --app command-line switch?

Now, on to enable browser.ssb.enabled. If it does what I hope, I might end up sticking to the last version that supports it for a while. To each one their priorities.

it is the decision that makes sense at this time.

Could you elaborate on why it makes sense?

You only refer to some ominous research, which you are not allowed to share, and which:

was not performed on the implementation in Firefox.

Firstly, this does not seem very transparent.
Secondly, how can you justify removing a feature because

user research found little to no perceived user benefit

when the user research was performed on a different implementation?

For what it's worth, Windows 10 users already have Edge Chromium: without having to abandon Firefox entirely, I will use Edge's PWA implementation for PWAs while using Firefox for everything else.

That's quite enough of that. A lot of these comments break the bmo etiquette guide (abuse, threats, and "I agree" comments without other substance) and/or the participation guidelines (be respectful; be professional). The pile-on isn't helping, nor is questioning Dave's motives (or those of other Mozilla employees), so I'm going to restrict comments on this bug.

We do our best to work on the features that are the most impactful for our mission with the limited resources we have, and right now all available data indicates that the current SSB implementation is not in that set. None of the dozens of comments here changes that.

Restrict Comments: true

(In reply to heapifyman from comment #25)

it is the decision that makes sense at this time.

Could you elaborate on why it makes sense?

As Gijs says, we have limited resources and so have to spend those resources on work that appears to have the most impact on our mission. Based on the available data we have (both the research we performed as well as looking at how Chrome and Edge's implementations are being received) PWAs on desktop fall behind other work right now.

Secondly, how can you justify removing a feature because

user research found little to no perceived user benefit

when the user research was performed on a different implementation?

The research was performed on something very close to what we envisioned our implementation looking like and so its results give us a good indication of how our implementation would be received.

(In reply to dreadnaut from comment #23)

Do you know if this will affect work on #1283670, the --app command-line switch?

PWAs were essentially the route to implementing that feature so I expect to wontfix that bug as a part of this.

(In reply to landsman from comment #20)

(In reply to Dave Townsend [:mossop] from comment #15)
This is very sad! PWA is future of agile apps development. Please let's consider this decision again. Is there something what the community can do?

The problem is that even if someone volunteered a patch that completes implementation we would have to spend resources on reviewing that and the ongoing maintenance costs. If there is some hard data somewhere we've missed that shows we would gain more market share by implementing this than other projects then that would sure be useful though!

Duplicate of this bug: 1685906
Pushed by dtownsend@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/634e8801b8b6
Remove the site specific browser feature. r=Gijs
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
You need to log in before you can comment on or make changes to this bug.