Closed Bug 1682910 Opened 10 months ago Closed 9 months ago

The top & bottom of the print preview page glitches when clicking the vertical scrollbar buttons

Categories

(Core :: Panning and Zooming, defect)

All
Windows
defect

Tracking

()

RESOLVED DUPLICATE of bug 1682919
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- fixed

People

(Reporter: emilghitta, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Attached image Glitch.gif

Affected versions

  • Firefox 85.0a1 (BuildId:20201214091023)
  • Firefox 84.0 (BuildId;20201211215739) - Please note that the print.tab_modal.enabled pref is disabled by default.
  • Firefox 85.0b2 (BuildId:20201215185920)

Affected platforms

  • Windows 10 64bit

Unaffected platforms

  • Ubuntu 20.04 64bit.
  • macOS 10.15

Steps to reproduce

  1. Launch Firefox.
  2. Access the following webpage
  3. Hit CTRL + P in order to open the print preview.
  4. Hold the click on the down arrow button from the print preview’s vertical dropdown.

Expected result

  • No UI issues are encountered after pressing the vertical scroll bar buttons.

Actual result

  • Print preview glitches when clicking the vertical scrollbar buttons

Regression Range

Notes

  • For further information please observe the attached screencast.
  • [Suggested Severity] I think that S4 fits for this issue.

Hi Botond,

It seems that mozregression pointed out Bug 1669861 for causing this regression.

Can you please take a look?

Thank you!

Flags: needinfo?(botond)
See Also: → 1682919

Based on the similar symptoms, this is likely the same issue as bug 1682919. I'll start with that one as it has a reduced testcase, and once I have a fix I'll check if it fixes this too.

Depends on: 1682919
Flags: needinfo?(botond)
See Also: 1682919
Has Regression Range: --- → yes
Has STR: --- → yes

Confirmed that this is fixed by the patch in bug 1682919.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1682919
You need to log in before you can comment on or make changes to this bug.