Closed Bug 1683244 Opened 1 year ago Closed 1 year ago

Cannot save multiple selected link of Pageinfo media tab

Categories

(Firefox :: Page Info Window, defect)

Firefox 84
Desktop
Windows 10
defect

Tracking

()

RESOLVED FIXED
86 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- wontfix
firefox85 + fixed
firefox86 + fixed

People

(Reporter: alice0775, Assigned: timhuang)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(2 files)

[Tracking Requested - why for this release]: The feature of Page Info is regressed by Bug 1641270

Reproducible: always

Steps to reproduce:

  1. Open Web Page e.g. https://en.wikipedia.org/wiki/Main_Page
  2. Right click on the page and choose "View Page Info"
  3. Select Media tab of Page Info dialog
  4. Select multiple link(or Select All)
  5. Click [Save As...]
  6. Select a folder and click [Select Folder]

Actual Results:
Nothing happens.
The following an error message in Browser Console:

Uncaught 
Exception { name: "NS_ERROR_XPC_BAD_CONVERT_JS", message: "Could not convert JavaScript argument arg 1 [nsIWebBrowserPersist.savePrivacyAwareURI]", result: 2153185289, filename: "chrome://global/content/contentAreaUtils.js", lineNumber: 480, columnNumber: 0, data: null, stack: "internalPersist@chrome://global/content/contentAreaUtils.js:480:13\ncontinueSave@chrome://global/content/contentAreaUtils.js:371:20\ninternalSave@chrome://global/content/contentAreaUtils.js:278:5\nsaveAnImage@chrome://browser/content/pageinfo/pageInfo.js:739:23\nsaveMedia/<@chrome://browser/content/pageinfo/pageInfo.js:775:24\nfpCallback_done@chrome://browser/content/pageinfo/pageInfo.js:666:16\n", location: XPCWrappedNative_NoHelper }
contentAreaUtils.js:480

Expected Results:
Download starts

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=e12b84262d8b4a09cd91f094436dc5edda03c39d&tochange=e93201b4e9087963e449099650d63bdb3dcbb2c2

Assignee: nobody → tihuang
Status: NEW → ASSIGNED

The root cause is that it doesn't pass the cookieJarSettings parameter
when calling the internalSave() in pageInfo.js. This patch fixes this by
passing the correct cookieJarSettings which was passed via the
'PageInfo:getData' message.

Duplicate of this bug: 1683308
Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/428185236755
Part 1: Fix the issue that `save As` of multiple selected links in PageInfo media tab doesn't work. r=smaug
https://hg.mozilla.org/integration/autoland/rev/f29352343a09
Part 2: Add test cases to ensure the 'Save As' in the media tab of the pageInfo uses the correct partitionKey. r=smaug,dimi
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch

The patch landed in nightly and beta is affected.
:timhuang, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(tihuang)
Duplicate of this bug: 1684326

Comment on attachment 9193940 [details]
Bug 1683244 - Part 1: Fix the issue that save As of multiple selected links in PageInfo media tab doesn't work. r?smaug!

Beta/Release Uplift Approval Request

  • User impact if declined: The downloading of multiple selected media items won't work.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It has only a few lines of changes and only affects the pageInfo.
  • String changes made/needed: None
Flags: needinfo?(tihuang)
Attachment #9193940 - Flags: approval-mozilla-beta?
Attachment #9193941 - Flags: approval-mozilla-beta?

Comment on attachment 9193940 [details]
Bug 1683244 - Part 1: Fix the issue that save As of multiple selected links in PageInfo media tab doesn't work. r?smaug!

approved for 85.0b5

Attachment #9193940 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9193941 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.