Closed Bug 1684151 Opened 2 years ago Closed 2 years ago

NewTab page - center the action with the close button inside the onboarding message

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
89 Branch
Iteration:
89.1 - Mar 22 - Apr 4
Tracking Status
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- wontfix
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- verified

People

(Reporter: cfogel, Assigned: emcminn)

Details

Attachments

(2 files)

Affected versions

  • 85.0b4, 86.0a1(2020-12-22), 84.0.1;

Affected platforms

  • macOS 10.15, Windows 10

Steps to reproduce
browser.newtabpage.activity-stream.asrouter.devtoolsEnabled - set on true

  1. Launch Firefox, access about:newtab#asrouter trigger any message on the NewTab page (ex: NEWSLETTER_TEST_SCENE1_SECTION_TITLE_ICON); or open NewTabs on a fresh profile until such a message is displayed;
  2. Resize the browser width so it takes up half of screen (or less);

Expected result

  • set the vertical center of the action and close button to be the same;

Actual result

  • the message, if it takes up more than one row is not centered with the close button;

Regression range

  • not a regression;

Additional notes

  • set S4 as severity since it's with no impact, main issue being that it appears offset with long messages
Has STR: --- → yes
Component: New Tab Page → Messaging System
Assignee: nobody → emcminn
Iteration: --- → 86.3 - Jan 11 - Jan 24
Priority: -- → P1
Iteration: 86.3 - Jan 11 - Jan 24 → 87.1 - Jan 25 - Feb 7
Attachment #9198288 - Attachment description: Bug 1684151 - center the close button with the action inside longer snippets at smaller screen widths → Bug 1684151 - Move the snippet close button to the upper right corner

Hi Aaron, this isn't an urgent request, but Punam and I wanted to check with you.
Since we don't have a consistent way to position the close button relative to the action button due to the way snippets are structured, we figured it would be safer to position the close button in the upper right corner. This will keep the position of the button consistent across all snippets no matter the content, at all screen widths. As long as this is ok from a UX perspective, that's what we'll go with. Thanks!

Flags: needinfo?(abenson)
Iteration: 87.1 - Jan 25 - Feb 7 → 87.2 - Feb 8 - Feb 21
Iteration: 87.2 - Feb 8 - Feb 21 → 88.1 - Feb 22 - Mar 7
Iteration: 88.1 - Feb 22 - Mar 7 → 88.2 - Mar 8 - Mar 21

Including Ryan for UI feedback

Iteration: 88.2 - Mar 8 - Mar 21 → 89.1 - Mar 22 - Apr 4
Flags: needinfo?(rcasey)

Hi Emily, just catching up on this. So to be clear your suggestion is to move the X close button to the to-right corner of the snippet, so it would be inline with the title "Messages from Firefox" on the left, correct? If so I think that makes sense. thanks! emcminn@mozilla.com

Flags: needinfo?(rcasey)
Attachment #9198288 - Attachment description: Bug 1684151 - Move the snippet close button to the upper right corner → WIP: Bug 1684151 - Move the snippet close button to the upper right corner
Attachment #9198288 - Attachment description: WIP: Bug 1684151 - Move the snippet close button to the upper right corner → Bug 1684151 - Move the snippet close button to the upper right corner
Pushed by emcminn@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4f96f66d3690
Move the snippet close button to the upper right corner r=pdahiya
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

I don't see a huge need to uplift this to Beta, but it does graft cleanly and seems relatively low-risk if you wanted to nominate it.

(In reply to Ryan Casey from comment #4)

Hi Emily, just catching up on this. So to be clear your suggestion is to move the X close button to the to-right corner of the snippet, so it would be inline with the title "Messages from Firefox" on the left, correct? If so I think that makes sense. thanks! emcminn@mozilla.com

That's what we did! Thanks for your feedback, Ryan :)

Flags: needinfo?(emcminn)

I have verified that the X "Close" button is correctly displayed in the top-right corner of the snippet on full-screen width, half-screen width, and minimum width using the STR from the description with latest Firefox Nightly 89.0a1 (Build ID: 20210419094740) on Windows 10 x64, macOS 11.2.3, and Ubuntu Linux 20.04.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.