Closed Bug 1684261 Opened 9 months ago Closed 9 months ago

Fix build with Rust nightly

Categories

(Firefox Build System :: General, defect)

defect

Tracking

(firefox-esr7886+ fixed, firefox85- wontfix, firefox86 fixed)

RESOLVED FIXED
86 Branch
Tracking Status
firefox-esr78 86+ fixed
firefox85 - wontfix
firefox86 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(1 file)

dependency (nix) specification is ambiguous. Only one of branch, tag or rev is allowed.

Fixes errors like:

dependency (nix) specification is ambiguous. Only one of branch, tag or rev is allowed.

I've left the most specific dependency, but for wgpu the rev is not
right, so I've kept the branch which effectively preserves behavior.

Assignee: nobody → emilio
Status: NEW → ASSIGNED
Assignee: emilio → nobody
Status: ASSIGNED → NEW
Assignee: nobody → emilio
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/48f46a7eada9
Fix build with rust nightly. r=jrmuizel
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch

Fwiw, maybe this should be backported to release or at least to esr78. Those fail to build with the just-released rust 1.50.

Flags: needinfo?(emilio)

Comment on attachment 9194752 [details]
Bug 1684261 - Fix build with rust nightly. r=jrmuizel,#build

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Build fix
  • User impact if declined: None
  • Fix Landed on Version: 86
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky, build only change.
  • String or UUID changes made by this patch: none
Flags: needinfo?(emilio)
Attachment #9194752 - Flags: approval-mozilla-esr78?

thunderbird 78.7.1 also fails with rust 1.50.

No need to track tb separately AIUI, there's no tb-specific change.

Comment on attachment 9194752 [details]
Bug 1684261 - Fix build with rust nightly. r=jrmuizel,#build

Approved for 78.8esr.

Attachment #9194752 - Flags: approval-mozilla-esr78? → approval-mozilla-esr78+
Duplicate of this bug: 1692363
You need to log in before you can comment on or make changes to this bug.