Closed Bug 1684772 Opened 3 months ago Closed 3 months ago

Move editor/ui into suite/editor

Categories

(SeaMonkey :: Composer, task)

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey 2.83

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

Details

Attachments

(5 files)

As editor/ui is now only used by SeaMonkey, it should be moved into suite.
Structure under suite/editor/ would be:
base/content/
components/dialogs/content/
components/prefs/content/
components/texzilla/content/
modules/
profile/
Locale files would be under suite/locales/en-US/chrome/editor and subdirectories of dialogs and pref

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.7
Risk to taking this patch (and alternatives if risky): minimal
String changes made by this patch: strings moved but no new ones

Attachment #9195143 - Flags: review?(frgrahl)
Attachment #9195143 - Flags: approval-comm-release?
Attachment #9195143 - Flags: approval-comm-esr60?

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.7
Risk to taking this patch (and alternatives if risky): minimal
String changes made by this patch: none

This is for older branches that don't use l10n-central

Attachment #9195144 - Flags: review?(frgrahl)
Attachment #9195144 - Flags: approval-comm-release?
Attachment #9195144 - Flags: approval-comm-esr60?

bash script for moving the files on l10n-central, based on the one from Bug 1571687 (unless there is a better way of doing it now).

Attachment #9195145 - Flags: review?(francesco.lodolo)

Comment on attachment 9195145 [details]
Bug-1684772_move-editor-locales.bash

I'm going to rewrite this to add it to my own update scripts. Note that this shouldn't be a hg mv, but a hg cp.

And I will need to run it after the changes landed and are exposed in cross-channel.

Attachment #9195145 - Flags: review?(francesco.lodolo) → feedback+

comm-central version

Attachment #9195744 - Flags: review?(frgrahl)

Comment on attachment 9195143 [details] [diff] [review]
1684772-editor-move-2537.patch

LGTM ra+ for 2.53 and 2.57 git release branches only.

Attachment #9195143 - Flags: review?(frgrahl)
Attachment #9195143 - Flags: review+
Attachment #9195143 - Flags: approval-comm-release?
Attachment #9195143 - Flags: approval-comm-release+
Attachment #9195143 - Flags: approval-comm-esr60?
Attachment #9195143 - Flags: approval-comm-esr60+

Comment on attachment 9195144 [details] [diff] [review]
1684772-l10n-toml-2537.patch

LGTM ra+ for 2.53 and 2.57 git release branches only.
Must not land on comm-central.

Attachment #9195144 - Flags: review?(frgrahl)
Attachment #9195144 - Flags: review+
Attachment #9195144 - Flags: approval-comm-release?
Attachment #9195144 - Flags: approval-comm-release+
Attachment #9195144 - Flags: approval-comm-esr60?
Attachment #9195144 - Flags: approval-comm-esr60+

Comment on attachment 9195744 [details] [diff] [review]
1684772-editor-move-cc.patch

Tested and working.

Flod, can we land this on comm-central or wait?

Flags: needinfo?(francesco.lodolo)
Attachment #9195744 - Flags: review?(frgrahl) → review+

(In reply to Frank-Rainer Grahl (:frg) from comment #8)

Comment on attachment 9195744 [details] [diff] [review]
1684772-editor-move-cc.patch

Tested and working.

Flod, can we land this on comm-central or wait?

You can land, no blocker.

Flags: needinfo?(francesco.lodolo)

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/649dfb319e7a
Move editor/ui into suite/editor. r=frg DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

Currently running the script (e.g. tested on Italian first https://hg.mozilla.org/l10n-central/it/rev/56afe44979fe8bf1dcaa2b2679a467529fce8f04)

You might want to send out an email to dev-l10n later, since some locales will see a bump in missing strings for SM.

local build did fine. mach build merge-it picked up the right copy. Made sure by nuking /editor from my l10n-central it local copy.

Thanks.

I was wondering why this failure only shows up sometimes. Maybe the l10n linter only runs if any string files were changed? Anyway, still needed ans shows up e.g. for https://treeherder.mozilla.org/jobs?repo=comm-central&selectedTaskRun=cKxkZsdyRUGB0FbruOy6fg.0

Comment on attachment 9195922 [details] [diff] [review]
bug1684772_l10nlint.patch

If Rob is not available at the moment I or IanN can r+ it. I missed this file when looking at the original patches.

The .eslintignore and .hgignore also seem to contain references to no longer existing directories (at least mozilla and editor) so maybe it is time for a housecleaning followup bug.

Comment on attachment 9195922 [details] [diff] [review]
bug1684772_l10nlint.patch

Review of attachment 9195922 [details] [diff] [review]:
-----------------------------------------------------------------

Oh I was just going to fix that... okay. :)
Attachment #9195922 - Flags: review?(rob) → review+
Duplicate of this bug: 1686429

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/0963794f6a5b
remove editor/ui from linting. r=rjl

Target Milestone: --- → seamonkey 2.83
You need to log in before you can comment on or make changes to this bug.