Conversion of 8-bit Cyrillic headers is highly desired

VERIFIED DUPLICATE of bug 77903

Status

--
enhancement
VERIFIED DUPLICATE of bug 77903
16 years ago
10 years ago

People

(Reporter: valentine.iourine, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1) Gecko/20020826

Despite being standard-uncompliant, 8-bit mail headers are widely used in Russia
and ex-USSR. In such configuration, both major clients (NS and OE) convert the
headers of the outgoing message in the same way as the body. (Not sure about
Outlook and The Bat, yet hardly they act differently).


Reproducible: Always

Steps to Reproduce:
1. Configure NS, Mozilla (any OS) or OE to send messages with 8-bit headers.
2. Send a Cyrillic test message (e.g. subject "АБВабв" and body "АБВабв")
3. Receive the message with Mozilla for Win32 (any version) and try reading the
Subject line.

Actual Results:  
8-bit headers are displayed as is (typically in raw koi8-r, as most mailers
convert messages to this standard codepage befor sending). In the above example,
Subject reads "бвчБВЧ".

Note: When replying to a message, 8-bit headers are converted correctly
nevertheless.

Expected Results:  
Convert all 8-bit headers in the same way as message body, i.e. FROM the charset
specified for the body (or the 1st text/something section) TO the current
charset specified in View menu.

The behavior of mail client in such non-standard situation is not specified,
thus it is up to developer to guess which way is better. The proposed behavior
seems to be optimal since it will satisfy the greatest portion of messages
actually circulating in Russian language (as compared to the other alternatives).

Probably the same behavior might be applied to other languages with multiple
codepages (e.g., Ukrainian or Greek). Consult people communicating in these
languages.

To my experience since NS 1.2, poor and too formal Cyrillic support under
Windows was one of the key contributors to NS's failure in Russia, despite
drastic drawbacks of MS mailers of that time. Please do not step on the same
rake again.

Comment 1

16 years ago
same as bug# 77903?
(Reporter)

Comment 2

16 years ago
Yes, it is exactly what was proposed by Alexey Chernyak in Additional comments 1 
and 5 - 
http://bugzilla.mozilla.org/show_bug.cgi?id=77903#c1
http://bugzilla.mozilla.org/show_bug.cgi?id=77903#c5

In addition, same guessing rule should be applied if the charset is specified as 
UNKNOWN in quoted-printable or base64 headers. (Currently a single question mark 
is displayed.)

Sorry for codes in the original report. What I meant as a simple Cyrillic test 
was a string of the first three Cyrillic letters: "ABVabv".

*** This bug has been marked as a duplicate of 77903 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
verified as a dup of 77903
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.