Closed Bug 1684969 Opened 11 months ago Closed 10 months ago

Marionette has conflicting python requirements

Categories

(Testing :: Marionette, defect, P3)

Default
defect

Tracking

(firefox87 fixed)

RESOLVED FIXED
87 Branch
Tracking Status
firefox87 --- fixed

People

(Reporter: mhentges, Assigned: jgraham)

References

Details

Attachments

(1 file)

While upgrading virtualenv (and, transitively, pip), the WPT tests began failing due to the new pip resolver not liking Marionette's dependencies.

In the meantime, I'm adjusting mozharness to tell pip to use the legacy resolver, but this will only work until pip@21.0.

See Also: → 1680802

What's broken here is:

[task 2021-01-04T16:20:49.497Z] 16:20:49     INFO -  ERROR: Cannot install -r /builds/worker/workspace/build/tests/config/marionette_requirements.txt (line 3) and h2 3.2.0 (from /builds/worker/workspace/build/tests/tools/wpt_third_party/h2) because these package versions have conflicting dependencies.
[task 2021-01-04T16:20:49.497Z] 16:20:49     INFO -  The conflict is caused by:
[task 2021-01-04T16:20:49.497Z] 16:20:49     INFO -      The user requested h2 3.2.0 (from /builds/worker/workspace/build/tests/tools/wpt_third_party/h2)
[task 2021-01-04T16:20:49.497Z] 16:20:49     INFO -      wptserve 3.0 depends on h2==3.0.1
[task 2021-01-04T16:20:49.497Z] 16:20:49     INFO -  To fix this you could try to:
[task 2021-01-04T16:20:49.497Z] 16:20:49     INFO -  1. loosen the range of package versions you've specified
[task 2021-01-04T16:20:49.497Z] 16:20:49     INFO -  2. remove package versions to allow pip attempt to solve the dependency conflict
[task 2021-01-04T16:20:49.498Z] 16:20:49     INFO -  ERROR: ResolutionImpossible: for help visit https://pip.pypa.io/en/latest/user_guide/#fixing-conflicting-dependencies

This is the requirements file:
https://searchfox.org/mozilla-central/source/testing/config/marionette_requirements.txt

Web-Platform third party packages are coming from:
https://searchfox.org/mozilla-central/source/testing/web-platform/tests/tools/third_party

James, mind having a look? Thanks.

Flags: needinfo?(james)
Severity: -- → S3
Priority: -- → P3

I think just specifying the dep as a lower bound is good enough for now? I suppose we might want to have a <4 dependency as well, but the (lack of) commitment to backwards compat/semver in the Python ecosystem doesn't give me much confidence that would be especially meaningful.

Flags: needinfo?(james)
Assignee: nobody → james
Status: NEW → ASSIGNED

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:jgraham, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(james)
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/dfb3738293ce
Specify wptserve h2 dependency as a lower bound, r=mhentges
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/27393 for changes under testing/web-platform/tests
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
Upstream PR merged by moz-wptsync-bot
Flags: needinfo?(james)
See Also: → 1690026
You need to log in before you can comment on or make changes to this bug.