behaviour of "open unrequested windows" feature

RESOLVED DUPLICATE of bug 102481

Status

RESOLVED DUPLICATE of bug 102481
16 years ago
14 years ago

People

(Reporter: tobias-mailings, Assigned: asa)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Hello all,
I have disabled the "open unrequested window" feature in Mozilla in order to
prevent popups. However, my company is using Outlook and also providing the
Outlook Web Access. An if I disable the open unrequsted feature, I can't reply
or forward emails anymore because a new window should open but it doesn't. Here
is the part of the html code that does it, seems some ActiveX/ASP stuff is not
working properly together with this nice "NOT open unrequested window" feature.

Just check for the parts relating to "forward" or "reply". There are commands
such as:

window.location="commands.asp?command=delete&obj=00000000D77818C16...........

and

<a href="JavaScript:DoCommand('reply')">  
<img SRC="/exchange/forms/reply.gif" Alt="Reply to sender" align="middle"
border=0></a>

Thanks,
Tobias

here is the full part of it:


<script language="Javascript">

function openNewWindow(fileName,windowName,theWidth,theHeight) {
	if (windowName == "newMessageWindow") 
	{
		//generate random window ID

		 windowName = new String(Math.round(Math.random() * 100000));

	}
	window.open(fileName,windowName,"toolbar=0,location=0,directories=0,status=1,menubar=1,scrollbars=1,resizable=1,width="+theWidth+",height="+theHeight)
}

</script>

<!DOCTYPE HTML PUBLIC \"-//IETF//DTD HTML 3.2//EN\">


<html>
<head>
<title>usudsf</title>
</head>
<script language=javascript>


function DoCommand(szCommand) {
  
    if (szCommand == "reply") {
     
window.location="commands.asp?command=reply&obj=00000000D77818C16893D211964A00805F315E800700C10FC87CB778D211964600805F315E8000000007483D0000150E204E37AAD211980D0000F68947280000099FAAAB0000";
       
    }
          
    else if (szCommand == "delete"){
     
window.location="commands.asp?command=delete&obj=00000000D77818C16893D211964A00805F315E800700C10FC87CB778D211964600805F315E8000000007483D0000150E204E37AAD211980D0000F68947280000099FAAAB0000";
      
    }
     else if (szCommand == "replyall"){
     
window.location="commands.asp?command=replyall&obj=00000000D77818C16893D211964A00805F315E800700C10FC87CB778D211964600805F315E8000000007483D0000150E204E37AAD211980D0000F68947280000099FAAAB0000";
      
    }
     else if (szCommand == "forward"){
     
window.location="commands.asp?command=forward&obj=00000000D77818C16893D211964A00805F315E800700C10FC87CB778D211964600805F315E8000000007483D0000150E204E37AAD211980D0000F68947280000099FAAAB0000";
      
    }
     else if (szCommand == "replytofolder"){
     
window.location="commands.asp?command=replytofolder&obj=00000000D77818C16893D211964A00805F315E800700C10FC87CB778D211964600805F315E8000000007483D0000150E204E37AAD211980D0000F68947280000099FAAAB0000";
      
    }    


    else if (szCommand == "close"){
       window.close();
    }
    else if (szCommand == "next"){
      
      window.location="/exchange/item.asp?action=next";
    }
     else if (szCommand == "previous"){
      
      window.location="/exchange/item.asp?action=prev";
    }

}

</Script>

<body TEXT=000000 BGCOLOR=#c0c0c0 TOPMARGIN=4 LEFTMARGIN=4 text=000000
link=000000 vlink=000000 alink=000000>

<!--- begin toolbar --------->
<form>
<table BORDER=0 bgcolor=#c0c0c0 CELLSPACING=0 CELLPADDING=0 WIDTH="100%">
<tr>
<td width=100%>
<img src="/exchange/images/divider.gif" width=4 height=24 align="middle">



<a href="JavaScript:DoCommand('reply')">  
<img SRC="/exchange/forms/reply.gif" Alt="Reply to sender" align="middle"
border=0></a>

<img src="/exchange/images/divider.gif" width=4 height=24 align="middle">

<a href="JavaScript:DoCommand('replyall')">  
<img SRC="/exchange/forms/replyall.gif" Alt="Reply to all" align="middle"
border=0></a>

<img src="/exchange/images/divider.gif" width=4 height=24 align="middle">


<a HREF="JavaScript:DoCommand('replytofolder')">
<img SRC="/exchange/forms/ReplyFld.gif" alt='Reply to folder' align="middle"
WIDTH=24 HEIGHT=24 BORDER=0></a>

<img src="/exchange/images/divider.gif" width=4 height=24 align="middle">



<a href="JavaScript:DoCommand('forward')">  
<img SRC="/exchange/forms/forward.gif" Alt="Forward" align="middle" border=0
height=24 width=24></a>

<img src="/exchange/images/divider.gif" width=4 height=24 align="middle">

<a
href="JavaScript:parent.openNewWindow('/exchange/movcpy/root.asp?msgid=00000000D77818C16893D211964A00805F315E800700C10FC87CB778D211964600805F315E8000000007483D0000150E204E37AAD211980D0000F68947280000099FAAAB0000&folderid=00000000D77818C16893D211964A00805F315E800100C10FC87CB778D211964600805F315E8000000007483D0000&process=1','newMessageWindow',400,400)">
<img SRC="/exchange/forms/movcpy.gif" align="middle" Alt="Move/Copy" border=0
height=24 width=24></a>

<img src="/exchange/images/divider.gif" width=4 height=24 align="middle">



<a href="JavaScript:DoCommand('delete')">  
<img SRC="/exchange/forms/delmark.gif" Alt='Delete' align="middle" border=0
height=24 width=24></a>

<img src="/exchange/images/divider.gif" width=4 height=24 align="middle">



<a href="JavaScript:DoCommand('previous')"> 
<img SRC="/exchange/forms/prevmsg.gif" Alt="Read previous item" align="middle"
border=0 width=24 height=24></a>

<a href="JavaScript:DoCommand('next')">  
<img SRC="/exchange/forms/nextmsg.gif" Alt='Read next item' align="middle"
border=0 width=24 height=24></a>

<img src="/exchange/images/divider.gif" width=4 height=24 align="middle">



<a
href="JAVASCRIPT:openNewWindow('/exchange/help/READMSG.HTM','inlineHelpWindow',600,400)">
<img SRC="/exchange/images/help.gif" alt="Get help information on the current
window" align="middle" border=0 height=20 width=20></a>

</td>
You can't use this feature unless MS change their stupid Javascript :-(


*** This bug has been marked as a duplicate of 102481 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.