DNS: find way of supporting network.dnsCacheExpiration

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
17 years ago
12 years ago

People

(Reporter: bert690, Assigned: gordon)

Tracking

Trunk
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
Mozilla 1.1 caches DNS entries for a VERY long time and there is no way to
override it. In Netscape (and I believe earlier versions of Mozilla) I could
always include the following line in my prefs:

pref("network.dnsCacheExpiration", 30)

... in order to set the DNS cache expieration to 30 seconds, as opposed to the
gross 15 or some-odd MINUTE default.  This seems to be completely ignored by
Mozilla 1.1. Worse, the cache time seems to now be much more than 15 minutes.

I've forced an IP address change, verified it has been recorded by my nameserver
(TTL was 1 minute and it was abided by), yet 25+ minutes later Mozilla is still
attempting to load the page from the old address (and failing since the old
address is now invalid).  IE on the other hand has picked up the IP change
(after ~15 minutes) and is now loading the page just FINE. 

This is a MAJOR problem for us dynamic DNS users. Please fix!!!!

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1
Summary: overzealous DNS cache ignoring network.dnsCacheExpiration prefs setting and caching for WAY TOO LONG → DNS: find way of supporting network.dnsCacheExpiration

Comment 1

17 years ago
This summary is more readable and to the point...

We probably also need to change the cache so DNS caches entries for pinned
content differently than for session-based connections (IMAP, NNTP).

Updated

17 years ago
Keywords: helpwanted
to gordon.
Assignee: new-network-bugs → gordon

Comment 3

17 years ago
*** Bug 192127 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
My mozilla's been caching for hours. I'm considering uninstalling it altogether.

Comment 5

16 years ago
This very same problems appears in Mozilla-mach on Mac OS X also. 

I consider this a critical bug, since this could (in the worst case) lead to
compromising private data and identity theft, as forms and cookies may end up
sent to the wrong server. 

I would like to see this bug's SEVERITY set to CRITICAL. Also, please add
'PRIVACY' to the keywords section and set the OSs to 'All'. 

(I could also file a duplicate bug and set the fields accordingly, If this is
the preferred way)

Comment 6

16 years ago
Thomas: see bug 151929 (support for TTL) and bug 162871 (DNS 'pinning' forever)

Comment 7

16 years ago
adt: nsbeta1-
Keywords: nsbeta1nsbeta1-

Comment 8

16 years ago
*** Bug 208209 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
probably a duplicate of bug 162871.. should be solved by the DNS rewrite for
mozilla 1.6.
Depends on: 205726

Comment 10

16 years ago
RESOLVED/FIXED:
per Darin's comments.
Once I get organized in my new office, I'll actually test and verify this.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: verifyme
Resolution: --- → FIXED

Updated

12 years ago
Keywords: helpwanted, verifyme
You need to log in before you can comment on or make changes to this bug.