Closed Bug 1685694 Opened 2 years ago Closed 1 year ago

[Wayland] Screen sharing permission asked twice for Jitsi on GNOME Wayland

Categories

(Core :: WebRTC, defect, P3)

Firefox 84
x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jan.public, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:84.0) Gecko/20100101 Firefox/84.0

Steps to reproduce:

System info: Fedora 33, GNOME Wayland.

Sharing screens via Jitsi (https://meet.jit.si) by clicking on the Share screen button at the lower left.

  • Firefox ask permission: Select window or screen
  • Select Use operating system settings
  • Click Allow
  • Select Single window
  • Select the window you want to share
  • Click Share

Actual results:

A new window titled "Share screen", similar as the previous one appears.

Expected results:

The window should have been shared without presenting the "Share screen" window again.

Blocks: wayland
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

You're right, I can reproduce it. Not sure why Jitsi asks for the permissions twice. For instance BlueJeans or https://mozilla.github.io/webrtc-landing/gum_test.html (webrtc test page) ask only once. I expect Jitsi creates some screen preview or so.

Component: Widget: Gtk → WebRTC
Summary: Screen sharing permission asked twice for Jitsi on GNOME Wayland → [Wayland] Screen sharing permission asked twice for Jitsi on GNOME Wayland

Marking confirmed based on Comment 2. Thank you for filing the bug!

Severity: -- → S3
Status: UNCONFIRMED → NEW
Ever confirmed: true

Today I tested the behavior on the same system in a GNOME on Xorg session. I noticed that the behavior quite differs from the behavior on Wayland. In Xorg, you get a small preview of the window that you are going to share in the dropdown window when you select a specific window to share. Also, you do not have to provide permission twice.

It's because any access to screen sharing API needs permission from user on Wayland. Xorg does not need that, you can do anything you want on Xorg, the permission dialog you see on Xorg is just Firefox window, not a system one.

Priority: -- → P3

I noticed that I only have to provide the sharing permission once nowadays.
Using: 88.0.1 (64-bit) on Fedora GNOME Wayland.
Closing as: Resolved, WorksForMe.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.