Closed Bug 1686245 Opened 9 months ago Closed 9 months ago

Print to paper output gets stuck on paper per sheet 16 format, regardless of any new settings made inside the print modal

Categories

(Core :: Printing: Output, defect)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox85 --- affected
firefox86 --- ?

People

(Reporter: Anca, Unassigned)

References

(Blocks 2 open bugs)

Details

(Keywords: regressionwindow-wanted, Whiteboard: [print2021_v86] [old-ui-])

Attachments

(1 file)

Attached file about:support content

Affected versions

  • 85.0b7

Affected platforms

  • Windows 7

Steps to reproduce

  • Unfortunately I don’t have exact steps to reproduce this issue, on a clean profile I can’t reproduce it, not sure what was the trigger here, I’ve been using the same profile for a considerable amount of time, playing with different options before coming across on this behavior.

Tentative steps:

  1. Make sure print.tab_modal.enabled is set to true in about:config
  2. Open https://www.qq.com/?fromdefault
  3. Hit CTRL + P
  4. Make sure to previously print the page with Pages per sheet set on 16
  5. Stress different options inside the modal (perform actual print to paper with those options)
  6. Set paper per sheet on the default value 1
  7. Print the page

Expected result

  • The print to paper outcome reflects the changes made inside the print modal

Actual result

  • Print to paper outcome is stuck with paper per sheet 16 format (sample output)

Regression range

  • Still needs investigation to determine concrete steps

Additional notes

  • Captured profile
  • The outcome is stuck on 16 sheet format for any webpage that is printed
  • Browser restart, printer restart, print with paper size set on 4 ore 9 doesn’t fix the output
  • Any settings made inside the modal, takes place inside the preview, only the actual paper output is compromise
  • Only one page in 16 sheet format is displayed on paper, regardless the number of pages set to be printed
  • No other destination is affected
  • Old UI is not affected
  • Set this issue tentative as S3 since could be an edge case scenario and was reproduced only on Windows 7 with one particular profile
QA Whiteboard: [qa-regression-triage]
Type: task → defect

I have attempted reproducing your issue on Windows 7 and 10 with Beta v85.0b7 and v85.0v8, but I was unsuccessful.
Anca, can you still reproduce it on your original profile? Maybe you could perform a regressor investigation sing the profile on your system.
Alternatively, you could upload the profile in this bug so I can reattempt reproduction and regression investigation.
Thanks.

Using the same profile from yesterday I can no longer reproduce the issue after upgrading to beta 8. I will close this one as worksforme for now.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.