Closed Bug 1686525 Opened 2 years ago Closed 1 year ago

Automatically add the home button to the toolbar when homepage is customized

Categories

(Firefox :: Toolbars and Customization, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox88 --- verified
firefox89 --- verified

People

(Reporter: mstriemer, Assigned: mstriemer)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-toolbar])

Attachments

(1 file)

When a user customizes their homepage, the Home button should be added to the toolbar automatically so that the user can easily get to their homepage.

There's an open question about cases when we shouldn't do this, for example if the user has manually hidden the home button already (recently?).

Whiteboard: [proton-toolbar]

From Romain: Add the button if users did not manually remove it previously AND they manually set a custom URL for home

An option for recording if the user has removed the home button manually would be to create a listener similar to SearchWidgetTracker [1] to record a pref that the home button has been removed. It looks like this shouldn't get triggered by the code to automatically remove the home button with proton enabled, but could be good to confirm that.

[1] https://searchfox.org/mozilla-central/rev/5120ec68572d946bd15101cf2ee2eaf4a210724f/browser/components/customizableui/SearchWidgetTracker.jsm#41

Priority: -- → P2
Assignee: nobody → mstriemer
Status: NEW → ASSIGNED
Priority: P2 → P1

As per guidance from Vicky, for tracking, we're marking all the bugs that people are working on as P1.

Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/806b53629174
Add home button to toolbar when custom homepage is set r=mconley
Regressions: 1695104
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Verified that the home button is added to the toolbar if a custom homepage is set. Tests were performed on Firefox 88.0b3 and Nightly 89.0a1 (2021-03-25) under Windows 10, macOS 10.15.7 and Ubuntu 20.04

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.