Closed Bug 1686982 Opened 8 months ago Closed 8 months ago

The eBay Sponsored urlbar Top Site is not recognized as already open

Categories

(Firefox :: Top Sites, defect, P1)

Desktop
All
defect
Points:
1

Tracking

()

VERIFIED FIXED
Iteration:
86.3 - Jan 11 - Jan 24
Tracking Status
firefox84 --- verified
firefox85 --- verified
firefox86 --- affected

People

(Reporter: mheres, Assigned: dao)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached image ebay urlbar url.gif

[Notes]:

  • Not sure if it's related with the issue, but when the eBay Sponsored suggestion is opened, there is an "/" in the URL (ebay.de/?mkevt), but the "/" is missing when hovering the eBay Sponsored suggestion (ebay.de?mkevt).

[Affected versions]:

  • Firefox Beta 85.0b9 (Build ID: 20210112185508)
  • Firefox Release 84.0.2 (Build ID: 20210105180113)
  • Firefox Nightly 86.0a1 (Build ID: 20210114083245)

[Affected Platforms]:

  • Ubuntu 20.04
  • macOS 10.15
  • Windows 10

[Prerequisites]:

  • Have the latest Firefox Beta version installed and open.
  • Have the following preferences set:
  • browser.search.region set to DE / US / GB
  • browser.topsites.experiment.ebay-2020-1 set to true
  • browser.partnerlink.useAttributionURL set to true
  • browser.topsites.useRemoteSetting set to true

[Steps to reproduce]:

  1. Open a new tab page.
  2. Click inside the address bar.
  3. Click the eBay Sponsored suggestion.
  4. Repeat the first 3 steps.

[Expected result]:

  • The second time the eBay suggestion is clicked, the tab switches to the page opened in step 3.

[Actual result]:

  • The eBay suggestion doesn’t recognize that the page is already open in another tab.

[Additional Notes]:

  • The behavior of the tile is also different at ctrl+click - it opens the page in a new tab and focuses it instead of opening the link in the same tab.
  • Attached is a recording of the behavior.
Group: mozilla-employee-confidential
Blocks: 1686985
Duplicate of this bug: 1686980

(In reply to Maria Heres, :mheres, Ecosystem QA from comment #0)

Created attachment 9197376 [details]
ebay urlbar url.gif

[Notes]:

  • Not sure if it's related with the issue, but when the eBay Sponsored suggestion is opened, there is an "/" in the URL (ebay.de/?mkevt), but the "/" is missing when hovering the eBay Sponsored suggestion (ebay.de?mkevt).

That's the problem. I'll update the remote setting records to include /.

Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 86.3 - Jan 11 - Jan 24
Points: --- → 1
Priority: -- → P1

Updated the records in main-preview on stage and prod.

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED

I have verified that the issue is no longer reproducible. The URL has been modified to contain a "/" and when the user clicks on the eBay url version while another tab containing it is open, the tabs switches. The ctrl+click behavior is also consistent with the rest of the urlbar options.
Tested on Firefox Release 84.0.2 (Build ID: 20210105180113) and Firefox Beta 85.0 RC 1 (Build ID: 20210118153634) using the GB, US and DE experiments on Windows 10.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.