Closed Bug 1687170 Opened 8 months ago Closed 6 months ago

[sw-wr] Crash in [@ memcpy | scale_blit]

Categories

(Core :: Graphics: WebRender, defect, P3)

Desktop
Windows
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox87 --- affected
firefox88 --- affected

People

(Reporter: aosmond, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

Original filed as part of bug 1687124, seems to have begun happening more frequently with bug 1684170 (probably a lot more users without D3D11?):

When the issue hit the first time, there was also a crash in the background (got notification bar to submit it 10 minutes later): bp-589319e2-4cb6-42ff-809c-9df430210116

Crash report: https://crash-stats.mozilla.org/report/index/589319e2-4cb6-42ff-809c-9df430210116

Reason: EXCEPTION_ACCESS_VIOLATION_WRITE

Top 10 frames of crashing thread:

0 vcruntime140.dll memcpy f:\dd\vctools\crt\vcruntime\src\string\i386\memcpy.asm:194
1 xul.dll scale_blit gfx/wr/swgl/src/composite.h:65
2 xul.dll Composite gfx/wr/swgl/src/composite.h:441
3 xul.dll swgl::swgl_fns::LockedResource::composite gfx/wr/swgl/src/swgl_fns.rs:2397
4 xul.dll webrender_bindings::swgl_bindings::SwCompositeThread::process_job gfx/webrender_bindings/src/swgl_bindings.rs:754
5 xul.dll std::sys_common::backtrace::__rust_begin_short_backtrace<closure-0, tuple<>> ../e1884a8e3c3e813aada8254edfa120e85bf5ffca/library/std/src/sys_common/backtrace.rs:131
6 xul.dll core::ops::function::FnOnce::call_once<closure-0, tuple<>> ../e1884a8e3c3e813aada8254edfa120e85bf5ffca/library/core/src/ops/function.rs:227
7 xul.dll std::sys::windows::thread::{{impl}}::new::thread_start ../e1884a8e3c3e813aada8254edfa120e85bf5ffca//library/std/src/sys/windows/thread.rs:56
8 kernel32.dll BaseThreadInitThunk 
9 mozglue.dll patched_BaseThreadInitThunk mozglue/dllservices/WindowsDllBlocklist.cpp:591
Crash Signature: [@ memcpy | scale_blit] → [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit]
Duplicate of this bug: 1687250
Duplicate of this bug: 1687259
Duplicate of this bug: 1687260
See Also: → 1687265
Crash Signature: [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] → [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv]
Severity: -- → S4
Crash Signature: [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] → [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv]
Priority: -- → P3

This surfaced on Linux too.

Crash Signature: [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] → [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] [@ __memmove_avx_unaligned_erms | scale_blit]
Crash Signature: [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] [@ __memmove_avx_unaligned_erms | scale_blit] → [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] [@ __memmove_avx_unaligned_erms | scale_blit] [@ vcruntime140.dll | scale_blit ]
Crash Signature: [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] [@ __memmove_avx_unaligned_erms | scale_blit] [@ vcruntime140.dll | scale_blit ] → [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] [@ __memmove_avx_unaligned_erms | scale_blit] [@ vcruntime140.dll | scale_blit ] [@ linear_row_yuv ]
Crash Signature: [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] [@ __memmove_avx_unaligned_erms | scale_blit] [@ vcruntime140.dll | scale_blit ] [@ linear_row_yuv ] → [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] [@ __memmove_avx_unaligned_erms | scale_blit] [@ vcruntime140.dll | scale_blit ] [@ linear_row_yuv ] [@ __memcpy_sse2_unaligned_erms | scale_blit]

Added a new signature

Crash Signature: [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ linear_convert_yuv] [@ __memmove_avx_unaligned_erms | scale_blit] [@ vcruntime140.dll | scale_blit ] [@ linear_row_yuv ] [@ __memcpy_sse2_unaligned_erms | scale_blit] → [@ __memcpy_sse2_unaligned_erms | scale_blit] [@ __memcpy_ssse3 | scale_blit] [@ __memmove_avx_unaligned_erms | scale_blit] [@ linear_convert_yuv] [@ linear_row_yuv] [@ memcpy | scale_blit] [@ memcpy_repmovs | scale_blit] [@ vcruntime140.dll | scal…

Fairly high volume crash in 88 Nightly @ memcpy | scale_blit

Blocks: gfx-triage

This has not had any nightly crashes in the last 14 nightlies.

Do we have an idea of what fixed it?

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → WORKSFORME
No longer blocks: gfx-triage
Duplicate of this bug: 1693560
Crash Signature: scale_blit] → scale_blit] [@ unscaled_composite]
You need to log in before you can comment on or make changes to this bug.