Last Comment Bug 168727 - cannot close folder with single click on twistie
: cannot close folder with single click on twistie
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: unspecified
: x86 Windows 2000
: -- normal (vote)
: Phoenix0.2
Assigned To: Pierre Chanial
: Asa Dotzler [:asa]
: Marco Bonardo [::mak]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-14 16:47 PDT by Asa Dotzler [:asa]
Modified: 2002-10-01 01:42 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Asa Dotzler [:asa] 2002-09-14 16:47:40 PDT
cannot close folder with a click on the twisitie. must first double click on the
folder icon or name to close it then single clicks work on the twistie to toggle
open/close states.
Comment 1 Pierre Chanial 2002-09-15 11:14:50 PDT
It seems to be a tree bug. when following the above testcase, I get the
following assertion:
###!!! ASSERTION: bad row: 'aRowIndex >= 0 && aRowIndex < mRows.Count()', file
nsXULTreeBuilder.cpp, line 628
Break: at file nsXULTreeBuilder.cpp, line 628
JavaScript error: 
 line 0: uncaught exception: [Exception... "Component returned failure code:
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsITreeView.getParentIndex]"  nsresult:
"0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: <unknown filename>
:: onxblclick :: line 16"  data: no]

This assertion is triggered in tree.xml, in the click event handler
http://lxr.mozilla.org/seamonkey/source/xpfe/global/resources/content/bindings/tree.xml#732
There is no row selected, but after rebuiding the tree 'in bookmarksTree.xml, in
doCommand), b.selection.currentIndex is not equal to -1 as it should be. I've
seen it equal to a number > rowCount
Comment 2 Pierre Chanial 2002-09-15 11:16:02 PDT
arg, the testcase is:
- delete a bookmark in the bm
- click on a twisty
Comment 3 Pierre Chanial 2002-09-29 09:38:14 PDT
fixed
Comment 4 Asa Dotzler [:asa] 2002-09-30 15:42:51 PDT
verified fixed with todays build on win2K

Note You need to log in before you can comment on or make changes to this bug.