Closed Bug 1687732 Opened 3 years ago Closed 17 days ago

Perma OSX testing/mozbase/mozproxy/tests/test_recording.py::test_record_and_replay TEST-UNEXPECTED-FAIL | ssl.SSLCertVerificationError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate

Categories

(Testing :: Mozbase, defect, P5)

defect

Tracking

(firefox-esr115 unaffected, firefox120 unaffected, firefox121 wontfix, firefox122 wontfix, firefox123 wontfix, firefox124 fixed)

RESOLVED FIXED
124 Branch
Tracking Status
firefox-esr115 --- unaffected
firefox120 --- unaffected
firefox121 --- wontfix
firefox122 --- wontfix
firefox123 --- wontfix
firefox124 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: sergesanspaille)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: abutkovits [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=327261928&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/TlLlNio9RWywrJsC5LQuvA/runs/0/artifacts/public/logs/live_backing.log


[task 2021-01-20T15:51:53.757Z]  0:46.58 /Users/cltbld/tasks/task_1611156228/checkouts/gecko/testing/mozbase/mozproxy/tests/test_recording.py
[task 2021-01-20T15:51:53.758Z]  0:46.58 ============================= test session starts ==============================
[task 2021-01-20T15:51:53.758Z]  0:46.58 platform darwin -- Python 2.7.16, pytest-3.6.2, py-1.5.4, pluggy-0.6.0 -- /Users/cltbld/tasks/task_1611156228/checkouts/gecko/obj-x86_64-apple-darwin18.6.0/_virtualenvs/python-test/bin/python
[task 2021-01-20T15:51:53.758Z]  0:46.58 rootdir: /Users/cltbld/tasks/task_1611156228/checkouts/gecko, inifile: /Users/cltbld/tasks/task_1611156228/checkouts/gecko/config/mozunit/mozunit/pytest.ini
[task 2021-01-20T15:51:53.758Z]  0:46.58 collecting ... collected 1 item
[task 2021-01-20T15:51:53.758Z]  0:46.58 
[task 2021-01-20T15:51:53.758Z]  0:46.58 testing/mozbase/mozproxy/tests/test_recording.py::test_record_and_replay TEST-UNEXPECTED-FAIL
[task 2021-01-20T15:51:53.760Z]  0:46.58 
[task 2021-01-20T15:51:53.761Z]  0:46.58 =================================== FAILURES ===================================
[task 2021-01-20T15:51:53.761Z]  0:46.58 ____________________________ test_record_and_replay ____________________________
[task 2021-01-20T15:51:53.761Z]  0:46.58 
[task 2021-01-20T15:51:53.761Z]  0:46.58 args = ()
[task 2021-01-20T15:51:53.761Z]  0:46.58 recording_file = '/Users/cltbld/tasks/task_1611156228/checkouts/gecko/testing/mozbase/mozproxy/tests/files/new_recoding.zip'
[task 2021-01-20T15:51:53.761Z]  0:46.58 config = {'app': 'firefox', 'binary': 'firefox', 'host': '127.0.0.1', 'obj_path': '/var/folders/9w/gjfgmclx0fg6_2c_b07v2l4m000017/T/tmpyw2rEh', ...}
[task 2021-01-20T15:51:53.761Z]  0:46.58 obj_path = '/var/folders/9w/gjfgmclx0fg6_2c_b07v2l4m000017/T/tmpyw2rEh'
[task 2021-01-20T15:51:53.761Z]  0:46.58 
[task 2021-01-20T15:51:53.761Z]  0:46.58     def test_record_and_replay(*args):
[task 2021-01-20T15:51:53.761Z]  0:46.58         # test setup
[task 2021-01-20T15:51:53.762Z]  0:46.58         recording_file = os.path.join(here, "files", "new_recoding.zip")
[task 2021-01-20T15:51:53.762Z]  0:46.58 
[task 2021-01-20T15:51:53.762Z]  0:46.58         # Record part
[task 2021-01-20T15:51:53.762Z]  0:46.58         config = {
[task 2021-01-20T15:51:53.762Z]  0:46.58             "playback_tool": "mitmproxy",
[task 2021-01-20T15:51:53.762Z]  0:46.58             "recording_file": recording_file,
[task 2021-01-20T15:51:53.762Z]  0:46.58             "playback_version": "5.1.1",
[task 2021-01-20T15:51:53.762Z]  0:46.58             "platform": mozinfo.os,
[task 2021-01-20T15:51:53.762Z]  0:46.58             "run_local": "MOZ_AUTOMATION" not in os.environ,
[task 2021-01-20T15:51:53.762Z]  0:46.58             "binary": "firefox",
[task 2021-01-20T15:51:53.762Z]  0:46.58             "app": "firefox",
[task 2021-01-20T15:51:53.763Z]  0:46.58             "host": "127.0.0.1",
[task 2021-01-20T15:51:53.763Z]  0:46.58             "record": True,
[task 2021-01-20T15:51:53.763Z]  0:46.58         }
[task 2021-01-20T15:51:53.763Z]  0:46.58 
[task 2021-01-20T15:51:53.763Z]  0:46.58         with tempdir() as obj_path:
[task 2021-01-20T15:51:53.763Z]  0:46.58             config["obj_path"] = obj_path
[task 2021-01-20T15:51:53.763Z]  0:46.58             record = get_playback(config)
[task 2021-01-20T15:51:53.763Z]  0:46.58             assert record is not None
[task 2021-01-20T15:51:53.763Z]  0:46.58 
[task 2021-01-20T15:51:53.763Z]  0:46.58             try:
[task 2021-01-20T15:51:53.763Z]  0:46.58 >               record.start()
[task 2021-01-20T15:51:53.763Z]  0:46.58 
[task 2021-01-20T15:51:53.764Z]  0:46.58 testing/mozbase/mozproxy/tests/test_recording.py:46:```
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

Started appearing on tier 1 jobs.

Summary: Intermittent [tier2] testing/mozbase/mozproxy/tests/test_recording.py::test_record_and_replay TEST-UNEXPECTED-FAIL → Intermittent testing/mozbase/mozproxy/tests/test_recording.py::test_record_and_replay TEST-UNEXPECTED-FAIL
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 3 years ago2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 2 years ago1 year ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 1 year ago7 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 7 months ago6 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Status: REOPENED → RESOLVED
Closed: 6 months ago4 months ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---

@Serg, can you look at this python failure?
it turned perma after bug 1863411 landed.
Caught it so late because the test doesn't run so often.

Flags: needinfo?(sguelton)
Keywords: regression
Regressed by: 1863411
Summary: Intermittent testing/mozbase/mozproxy/tests/test_recording.py::test_record_and_replay TEST-UNEXPECTED-FAIL → Perma OSX testing/mozbase/mozproxy/tests/test_recording.py::test_record_and_replay TEST-UNEXPECTED-FAIL | ssl.SSLCertVerificationError: [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate

Set release status flags based on info from the regressing bug 1863411

I'm investigating this one, looks like the taskcluster-built python cannoit find the required certificates...

Flags: needinfo?(sguelton)

Set release status flags based on info from the regressing bug 1863411

Should the tests be disabled until this gets resolved?

Flags: needinfo?(sguelton)

Instead of trying to find the system certificates, something that may
depend on the running system, use the certifi package and have ssl point
to it.

Assignee: nobody → sguelton
Attachment #9379726 - Attachment description: Bug 1687732 - Bundle certifi certificates in taskcluster's Python on OSX r=jmaher → Bug 1687732 - Bundle certifi certificates in taskcluster's Python on OSX r=glandium
Pushed by sguelton@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b48cab2cc9dc
Bundle certifi certificates in taskcluster's Python on OSX r=jmaher
Status: REOPENED → RESOLVED
Closed: 4 months ago17 days ago
Resolution: --- → FIXED
Target Milestone: --- → 124 Branch
You need to log in before you can comment on or make changes to this bug.