Closed Bug 1687979 Opened 9 months ago Closed 9 months ago

Bookmark Restore submenu no longer appears at some scaling factors

Categories

(Core :: Widget: Gtk, defect)

Firefox 86
Unspecified
Linux
defect

Tracking

()

RESOLVED FIXED
Tracking Status
firefox-esr78 --- unaffected
firefox84 --- unaffected
firefox85 --- unaffected
firefox86 --- fixed

People

(Reporter: ke5trel, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

STR:

  1. Start with MOZ_ENABLE_WAYLAND=1 on Ubuntu 20.10.
  2. Open the Library window (Ctrl+Shift+O).
  3. Click Import & Backup > Restore.

Restore submenu fails to appear.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=f0ea749647d34c1a290b3839f7dc8aa8f28e4801&tochange=0c0b1e3fab140328571088a912eb77c046fb7217

Regressed by Bug 1645695.

Hm odd, can't reproduce that here.

Any extra information about scale, resolution etc.?

I see this on multiple Ubuntu 20.10 systems that are close to stock with no scaling. I tried changing scaling factor and found that it worked for most scales except 1.0, 1.3 and 1.6.

Summary: Bookmark Restore submenu no longer appears → Bookmark Restore submenu no longer appears at some scaling factors

(In reply to Kestrel from comment #2)

I see this on multiple Ubuntu 20.10 systems that are close to stock with no scaling. I tried changing scaling factor and found that it worked for most scales except 1.0, 1.3 and 1.6.

Kestrel, IIUC you have enabled experimental fractional scaling enabled, right? (https://www.linuxuprising.com/2019/04/how-to-enable-hidpi-fractional-scaling.html)

Can you try to turn it off and check with 100% and 200% scaling?
Thanks.

Flags: needinfo?(ke5trel)

Yes, I can reproduce that too, I just verified that with mozregression.
We need to revert this one, updated Bug 1645695.

Flags: needinfo?(ke5trel) → needinfo?(sheriffs)
Flags: needinfo?(sheriffs)

Fixed by backout of Bug 1645695.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

Sorry for being unclear, that was the font scaling factor I was referring to in Comment 2, the system scaling factor is 100%. Firefox scales its interface according to font scale in a very similar way to fractional scaling which can be confusing.

I can reproduce it on monitor with 200% scale factor and default font scale (1x). When I move Firefox window to a monitor with 100% scale, I can open all popups.

You need to log in before you can comment on or make changes to this bug.