Closed Bug 1688037 Opened 8 months ago Closed 8 months ago

windows sometimes stop repainting (OSX arm64)

Categories

(Core :: Widget: Cocoa, defect)

Firefox 85
ARM64
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1682713
Tracking Status
firefox85 --- affected
firefox86 --- affected

People

(Reporter: vlad, Unassigned)

References

Details

I've seen this a few times now; Firefox 85b9. Windows just stop repainting. If the window loses/gains focus, it gets repainted properly once, but any interaction with the window doesn't draw anything.

M1 Mac Mini, default Firefox 85b9 config (installed yesterday). WebRender is enabled. I can't trigger it to happen on demand; things work fine for hours and then they don't. No crashes or anything; I can quit the browser just fine and things reopen properly when I relaunch.

Seems to be related to leaving Firefox alone for a while, and having the mac turn off the display; coming back to the computer I see the issue. I can't reproduce manually via Sleep or Screen Saver though, will see if it happens reliably again after display standby.

See Also: → 1422855
Blocks: gfx-triage

Definitely related to leaving the mac and letting things go into power save. If I leave my mac and go away for an hour, when I come back and unlock, Firefox will be in this state. New windows are also created in this state -- the initial repaint happens, but no updates after that.

Happens with:

  • WebRender enabled or disabled (OpenGL compositing)
  • Big Sur 11.1
  • Big Sur 11.2 RC2 (20D62)

Graphics team thinks this might be in widget, and we don't have hardware. Wondering if the macos widget folks can help diagnose.

Component: Graphics → Widget: Cocoa
Flags: needinfo?(mstange.moz)
Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(mstange.moz)
Resolution: --- → DUPLICATE
Duplicate of bug: 1682713
No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.