Closed Bug 1688802 Opened 3 months ago Closed 2 months ago

Investigate removing focus from the address bar in about:welcome

Categories

(Firefox :: Messaging System, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
87 Branch
Iteration:
87.2 - Feb 8 - Feb 21
Tracking Status
firefox87 --- verified

People

(Reporter: pdahiya, Assigned: pdahiya)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

After installation, when users land on about:welcome, the browser's focus is on the address bar with the cursor blinking there. It distracts from starting onboarding flow.

Scope of this bug is to investigate if we can remove the focus from the awesome bar and determine if this can be done as an experiment.

https://jira.mozilla.com/browse/UJET-68

Hi Dao,

NI'ing as you have touched this code last :) , Code change in attached patch removes focus from urlbar for brief window of time when user lands on welcome page after installing Firefox. We would like to experiment if this change gets more user to try onboarding flow.

https://phabricator.services.mozilla.com/D103004#3341282

Will be great if you can give feedback (if this is the right place for removing focus) or redirect this to someone who knows this codebase more, thanks!

Flags: needinfo?(dao+bmo)

Hi Natalie,

Please see comment 2 (above), we want to make sure that this change won't interfere with anything the Search team is planning.

Flags: needinfo?(dao+bmo) → needinfo?(nraketic)
Severity: -- → S3
Iteration: --- → 87.1 - Jan 25 - Feb 7
Priority: -- → P1
Assignee: nobody → pdahiya
Status: NEW → ASSIGNED

Please see the reply in phabricator.

Flags: needinfo?(nraketic)
Iteration: 87.1 - Jan 25 - Feb 7 → 87.2 - Feb 8 - Feb 21

NI Dao to help review updated attached patch , thanks!

Flags: needinfo?(dao+bmo)
Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1a5c5bb711b4
Remove focus from the address bar in about:welcome r=dao,k88hudson

Doing another try run on linux seems to pass this test
https://treeherder.mozilla.org/jobs?repo=try&revision=fa8c0252a2f971488a0d36cd23e2c1596a167c44&selectedTaskRun=E77ZKMbBTLC2iXmhQzlQng.0

This failure is highly intermittent, looking at error logs in #comment 7 failure seems to be triggered from browser_aboutwelcome_multistage.js where browser_aboutwelcome_ExperimentAPI enrolls in 'mochitest-aboutwelcome' experiment and all subsequent test stays enrolled in experiment, this impacts browser_aboutwelcome_skipFocus.js which needs its own test content with skipFocus set as true.

NI @andreio to help debug why ExperimentAPI._store._deleteForTests("mochitest-aboutwelcome"); cleanup not working for above run, thanks!
https://searchfox.org/mozilla-central/source/browser/components/newtab/test/browser/browser_aboutwelcome_multistage.js#347

Flags: needinfo?(pdahiya) → needinfo?(andrei.br92)
Pushed by pdahiya@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/664cbe539d25
Remove focus from the address bar in about:welcome r=dao,k88hudson

We cache aboutwelcome experiments in prefs for fast sync access. store._deleteForTests will remove the enrollment from the file stored on disk but if cleanup isn't done through the normal unenroll flow then the pref for this experiment remains active. See test_ExperimentManager_enroll.js for a cleanup function. But I recommend doing something like

for experiment in store.getAllActive() {
  ExperimentManager.unenroll(experiment)
}
await BrowserTestUtils.waitForCondition(() => store.getAllActive().length === 0)

if this is an end to end test and not just small unit tests.

Flags: needinfo?(andrei.br92)
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

I have verified this enhancement and I can confirm the "Address Bar" is not automatically focused at first-startup if the browser.aboutwelcome.overrideContent pref is set to the value that Punam provided here. Also, we will perform a more thoughtfully testing round in the Firefox 87 Pre-Release phase which will conclude with a testing report.

Flags: needinfo?(dao+bmo)

This enhancement was part of the testing performed for "[PI-948] Remove focus from the address bar after install" feature. Considering this I am changing the status to Verified - Fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.