Closed Bug 1688883 Opened 1 year ago Closed 1 year ago

[tracker] remove email field

Categories

(Socorro :: General, task, P2)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: willkg, Assigned: willkg)

References

Details

The crash reporter for main process crashes for Firefox has an "Email" field which we use to solicit an email address from the user. We use this information in a few ways:

  1. if the user logs into crash stats with that email address, that triggers the "your_crash" state and we show that user the protected data in their crash report
  2. if the user asks us to delete crash data on our system that belongs to them, we use the email field as the identifier for which crash reports to remove
  3. folks have told me they've emailed users with particularly hard-to-reproduce problems, but I wasn't able to find proof of this when I was looking into usage of the Email field so it's unclear to me how compelling this usage is (bug #1626277)

Let's talk about the Email field a bit. There are a bunch of twists. We don't have an Email field in the crash reporter ui for content process crashes. We don't have an Email field in the auto-submit bar which asks users to submit unsubmitted crash reports. We don't have an Email field on about:crashes for crash reports submitted there. I'm pretty sure there's no Email field for any of the Fenix crash reporters.

So in the last week, for the Email field, we have this breakdown:

product count
Firefox 45k
Thunderbird 13k
Fennec 13k

That's out of 1.3 million crash reports processed in the same time period.

We don't want identifying information we're not using. With email addresses, I claim there should be a very compelling reason to be collecting and storing them.

Given this situation, I think it's time we remove the Email field.

This tracker bug covers that project.

Making this a P2 and grabbing it. It's one of the things I'm planning to tackle in 2021q1.

If you're reading this and you're concerned, please contact me directly as soon as possible.

Assignee: nobody → willkg
Status: NEW → ASSIGNED
Priority: -- → P2
Depends on: 1688905
Depends on: 1688907
Depends on: 1688908

I wrote up bug reports covering the changes needed in Antenna and Socorro.

I didn't write up a bug report(s) for removing the Email field from:

  1. the crash reporter code, dialogs, etc
  2. CrashAnnotations.yaml

I figure I'll get to writing those up at some point.

I sent an email to everyone with protected data access that I'm planning to remove the Email field. I want to mention it on Stability, too. Then I can start removing bits over the course of February.

I talked to Trust and Safety and they're OK with removing this field.

Project plan: https://docs.google.com/document/d/1k1VyyX5XNj8cPlGDzm0jFWHQynUL8ZjpMqiYyJCkeus/edit#

Depends on: 1691527
Depends on: 1691528
Depends on: 1692504
Depends on: 1692702

Status:

  1. I changed the collector to delete the Email data from incoming crash reports (bug #1688905). That took effect February 10th, 2021.
  2. All Email data will expire from Socorro 6 months from that date: August 10th, 2021 (or thereabouts--I forget exactly how "6 months" is defined).
  3. I wrote up bugs to cover the rest of the work required in Socorro to remove all functionality related to Email data. I plan to do that work in May 2021. At that point, it's unlikely anyone is using this data anymore since it'll only be in old crash reports.
  4. I changed the content process crash reporting client and removed the email field bits (bug #1691527). That's landed and will ride the Firefox 88 train.
  5. I changed the main process crash reporting client and removed the email field bits (bug #1691528). That's landed and will ride the Firefox 88 train.

Known outstanding work:

  1. Finish removing email-related functionality from Socorro. (5/2021)

I talked with Emily and we should also update the screenshot and remove the email language in the SUMO article about crash reporting:

https://support.mozilla.org/en-US/kb/mozillacrashreporter#w_getting-help-with-crash-reports

I submitted a revision for the SUMO article with a new screenshot and I removed the text about the email field.

AliceWyman fixed up the revision and approved it, so we're all set with the SUMO article.

The only two outstanding bits are bugs we need to do in a few months. Given that, I'm going to close this out and we'll get to those at that time.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.