Closed Bug 1688972 Opened 2 months ago Closed 2 months ago

FocusedChild fails when focus is in iframe

Categories

(Core :: Disability Access APIs, defect, P1)

defect

Tracking

()

RESOLVED FIXED
87 Branch
Tracking Status
firefox87 --- fixed

People

(Reporter: eeejay, Assigned: eeejay, NeedInfo)

References

(Blocks 1 open bug)

Details

(Whiteboard: [mac2020_2])

Attachments

(1 file)

Given the following url, with focus on the input
data:text/html,<iframe src="data:text/html,<input>"></iframe>

We get the following results, depending on process topography when calling FocusedChild on the top level doc:

  1. Non-e10s: We get the input accessible.
  2. e10s: We get null because the unique id passed back in RecvFocusChild won't resolve in the sending DocAccessibleParent since it is a member of a child doc.
  3. fission: We get null because no focused accessible is returned by the focus manager when focus is in a child doc.

We need to make all of these cases work like the non-e10s case.

A note about FocusedChild: For some archaic reason accessibles are expected to return a direct focused child, or null. Document accessibles (including child docs) return a focused descendant. This API design choice is out of the scope of this bug.

Severity: -- → S3
Blocks: 1687257
Blocks: 1684383
Duplicate of this bug: 1684383
No longer blocks: 1684383
No longer blocks: 1687257
Duplicate of this bug: 1687257
Priority: -- → P1
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4572c1ba670a
Make FocusedChild work across document/process boundaries. r=Jamie
Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b3216f1cfd1f
Make FocusedChild work across document/process boundaries. r=Jamie
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
Blocks: a11y-fission
Regressions: 1691930
You need to log in before you can comment on or make changes to this bug.