Closed Bug 1689437 Opened 3 months ago Closed 2 months ago

Honor pref values when displaying bookmarks toolbar in Skeleton UI

Categories

(Firefox :: Bookmarks & History, defect, P3)

defect

Tracking

()

VERIFIED FIXED
87 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox85 --- unaffected
firefox86 --- fixed
firefox87 --- verified

People

(Reporter: emalysz, Assigned: emalysz)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

We should honor the values for browser.toolbars.bookmarks.2h2020 and browser.toolbars.bookmarks.visibility to correctly show the margins in the skeleton UI

Attachment #9199861 - Attachment description: Bug 1689437, respect bookmarks.toolbars.bookmarks pref values to display bookmarks toolbar in skeleton UII → Bug 1689437, respect bookmarks.toolbars.bookmarks pref values to display bookmarks toolbar in skeleton UI
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/104410a56d07
respect bookmarks.toolbars.bookmarks pref values to display bookmarks toolbar in skeleton UI r=dthayer
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch

The patch landed in nightly and beta is affected.
:emalysz, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(emalysz)
Flags: needinfo?(emalysz)

Comment on attachment 9199861 [details]
Bug 1689437, respect bookmarks.toolbars.bookmarks pref values to display bookmarks toolbar in skeleton UI

Beta/Release Uplift Approval Request

  • User impact if declined: The skeleton UI can have slightly off margins if the user has the bookmarks toolbar enabled
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Conditions:
    For windows startup only.
    Ensure the browser.startup.preXulSkeletonUI set is set to true
    Enable bookmarks toolbar to only show on new tab (either through customization UI or by setting browser.toolbars.bookmarks.visibility to newtab and browser.toolbars.bookmarks.2h2020 to true.
  1. Navigate to a page that is not about:home or about:newtab (try google). Ensure the bookmarks toolbar disappears
  2. Close firefox
  3. Start up firefox again, ensuring the skeleton UI is shown
  4. Notice the space where the bookmarks toolbar is reflected in the skeleton UI
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No string changes
  • String changes made/needed: n/a
Attachment #9199861 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

I've managed to reproduce this bug using the steps from comment 6, on an affected Nightly build 87.0a1 (20210201094443). Thanks Emma, for the hints provided on slack.

The issue is verified as fixed on latest Nightly 87.0a1 (2021-02-09), under Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Emma, AFAIK, the skeleton UI is currently restricted to Nightly (https://searchfox.org/mozilla-beta/source/browser/app/profile/firefox.js#272-280). Do we need to uplift this patch to beta 86? Is there an 86 experiment with the Skeleton UI that would benefit from this uplift maybe? Thanks

Flags: needinfo?(emalysz)

Hey Pascal,
We're planning on running an experiment in 86 (Bug 1689450) with this pref turned on, so if it applies cleanly, we'd like to uplift

Flags: needinfo?(emalysz) → needinfo?(pascalc)

Comment on attachment 9199861 [details]
Bug 1689437, respect bookmarks.toolbars.bookmarks pref values to display bookmarks toolbar in skeleton UI

Low risk and needed by an experiment, approved for 86 beta 9.

Flags: needinfo?(pascalc)
Attachment #9199861 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.