accented characters in headers display wrong charachters

VERIFIED INVALID

Status

MailNews Core
Internationalization
VERIFIED INVALID
16 years ago
10 years ago

People

(Reporter: Javier Martínez, Assigned: nhottanscp)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
when I recieve messages with accented character (é, í, ó, etc) in the sender, to
and subject line, this characters are not represented as they ar, but with
sanscrit or other symbols like 翽.
if the character is in the midle of a line, the line doesn´t end

E.g. the subject Mitología Clásica is recieved in the message source as 
Subject: =?UNKNOWN?Q?mitolog=EDa_cl=E1sica?=
but in the Mail Programm is displayed as Subject: 翽

Comment 1

16 years ago
*** Bug 168966 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
Javier, could you please add more details to this bug report:what build are you
using, what mail server (POP, IMAP) and please attach a problematic message so
that we can rtake a look at it? Thanks.

Comment 3

16 years ago
I think "=?UNKNOWN?Q?" mean the sender do not know the encoding of the charset.
And therefore the receiving client won't know neither. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Comment 4

16 years ago
verified as such
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.