If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Mozilla should offer "plan B" when message was sent, but "Sent" folder is unavailable.

VERIFIED DUPLICATE of bug 28211

Status

MailNews Core
Composition
--
major
VERIFIED DUPLICATE of bug 28211
15 years ago
9 years ago

People

(Reporter: Aleksey Nogin, Assigned: Jean-Francois Ducarroz)

Tracking

({dataloss})

Trunk
mozilla1.3alpha
x86
Linux
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I would imagine there are many possible scenarious that would trigger this, but
here is one of them:

0) Change your connectivity/preferences/etc so that SMTP is available, but the
"Sent" folder is not. For example:
  a) Disconnect machine from the network with SMTP set to localhost and Sent
pointing to IMAP server.
  b) Point Sent to IMAP server, block copnnections to that server.
  c) Change "Sent preferences.
1) Compose a message in off-line mode, for "Send later".
2) Go to online telling Mozilla to send unsent messages.
3) Observe that (as expected) SMTP goes trough, but saving to Sent fails.

Expected: Mozilla falls back to "Plan B". There are many alternative "Plan B"s,
for example:
I) Save to Sent on Local Folders and pop up a warning telling user what happened.
II) If the Sent folder is and Offline folder, save the message in "Offline" mode
(so that it gets transferred to the server once it becomes available).
III) Pop up a warning telling user what happened and give user a choice of:
  a) Retry
  b) Save to Local Folders -> Sent
  c) Pick another folder
  d) Ignore the error and continue.

Actual: I get a warning telling that message was Sent, but not saved advising me
to "try again". Of course, there is no chance to "try again" since the message
is now completely gone (unless I had it CC/BCC to myself).

This bug is not limited to offline, although its consequences are worse
(dataloss) in the "Send Later" scenario. In "Send now", I get the warning that
message was sent, but not saved. After that the "Compose" window is still
around, but with most of the controls disabled. However it's not a complete
dataloss - I still get a chance to save it as Draft (and then move it from Draft
to Sent).

I've set it to Severity: major for the dataloss reasons.
(Reporter)

Comment 1

15 years ago
P.S. The last time I was able to reproduce this was with Build ID 2002091318
(trunk) running on Red Hat Linux.
Keywords: dataloss
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.3alpha

Comment 2

15 years ago
looks like a dupe of 28211 to me...
(Reporter)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 28211 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.