Closed Bug 169027 Opened 22 years ago Closed 20 years ago

can't select field name/multiple records in message headers

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 167010

People

(Reporter: bwucke+bug, Assigned: sspitzer)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020826

This is extension of functionality of Bug 61497. Although you can select contens
of a field in message headers, you can't select the field names, or mark several
fields at once.


Reproducible: Always

Steps to Reproduce:
1. Place mouse on a header field.
2. Press LMB and drag down.

Actual Results:  
The field is selected to its end.

Expected Results:  
The field and next fields are selected, just as if it was a plain text document.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
This bug must be *very* carful not to break the useful ability to LMB click on
e-mail addresses (To, From, CC, ..) and get a dropdown menu with: Add to
Addressbook, Copose Mail to, Copy e-mail Address, Create Filter.

Bug 91662 already broke subject line wraping (which wasn't the cause of that
bug). S all these fixes have so far made the overall situation worse than
before. (I have confidence that this is only a temporary setback)
I agree - although the behaviour could be switched to something more standard -
Like, LMB performs the default action - mailto:, while RMB brings pop-up menu,
just like RMB on any button... anyway, the kind of menu that pops up on RMB in
headers (maybe except "create filter from message" which could be a separate
option not connected to email links - or maybe "create filter from this address"
would be better?) should be default for handling mailto: links, no matter where.
(note Bug 166958 - mark this "depends on..."?)

IMO, it would be a big win, if the header part of display was html'ised (or at
least XUL'ised) and displayed just like a webpage. (want to keep the colors?
<body bgcolor="...) thus moving to DOM or making trivially correctable all the
layout bugs like too long lines not fitting, GUI misaligned, proper URL
handling, selecting, marking all etc.

Build 2002101412.

Please add a 'view raw header source' function to the 'View->Headers' menu item.
 A possible name to add to 'All' and 'Normal' might be 'Source' or 'Raw' -- the
response would be to duplicate the View -> Message Source' function, but showing
only the unedited header text.

When I look for header contents I look under 'View', then see 'Headers'. I then
expect to find functions related to viewing the header there.  Of course,
correcting the name of View -> Message Source to View->View Message Source would
also fix this -- Pardon me but I find that the current View->Message Source is
so badly misnamed that I continue to forget where I found the silly function the
*last* time I lost it.  A 'View->Headers->Raw' function would be placed where I
am guided to look, and would be named appropriately for it's location in the
menu taxonomy.

Showing the headers in a readonly separate window makes cut-and-paste easy to
report SPAM and email child porn problems.  Showing only the headers simplifies
life for those receiving 'header' information without the raw message text there
also.  Plus, I found today that it can be *tricky* selecting the header without
also catching the first tag of an HTML message when using 'View_>Message Source'.
"View > Message source" is a good choice, IMO, because it's similar to "View >
Page source" in browser or "View > HTML source" in composer.  Just a matter of
habit.  But "View > view message source" has two "view", don't you find this
word is redundant?

Moreover, Ctrl+U can be used by all three "View > ... source" mentioned here before.

As to your suggestion of "View > Headers > Raw", maybe it's necessary, or maybe
not.  Why so?  Because "View > headers > all" actually doesn't show *all*
headers.  Eg, if there're more than one field of "Received", only the last one
is displayed.  Maybe this is a bug?  If this is really a bug and if it's fixed,
and provided this very bug is fixed, "View > headers > all" or "View > headers >
raw" will actuall do the same thing (well, except the fields order).  
View headers>
- Brief (just "subject" and "from" what you get from clicking the "triangle" in
the corner of the headers. It's all there already, why not add?)
- Normal (leave as-is)
- Verbose (current "All")
- All (raw source. Warning, Bug 140055 would strike with long "References:"
fields in mailnews very often. This bug depends on? ) 

?
*** Bug 200787 has been marked as a duplicate of this bug. ***
Would be very nice if View source were a right click away from the message body
pane or header pane.  It didn't occurr to me to use the main menu bar until I
came here to complain about it.

*** This bug has been marked as a duplicate of 167010 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.