Closed Bug 1690901 Opened 3 years ago Closed 3 years ago

Split nsTableWrapperFrame::OuterBeginReflowChild with other clean-up

Categories

(Core :: Layout: Tables, task)

task

Tracking

()

RESOLVED FIXED
87 Branch
Tracking Status
firefox87 --- fixed

People

(Reporter: TYLin, Assigned: TYLin)

References

Details

Attachments

(3 files)

After bug 1690715, nsTableWrapperFrame::OuterBeginReflowChild becomes a method creating ReflowInput for both caption and inner table. We can split it into two separate methods rather than branching logic to handle both.

Split OuterBeginReflowChild() so that we don't need to branch logic for
caption and inner table.

Rename the methods because OuterBeginReflowChild() only creates the ReflowInput,
and has nothing to do with actual reflow.

Depends on D104105

Attachment #9201257 - Attachment description: Bug 1690901 Part 1 - Make nsTableWrapperFrame::GetCaptionSide() a const method. → Bug 1690901 Part 1 - Make GetCaptionSide() and HasSideCaption() const methods.
Blocks: 1527734
Pushed by aethanyc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4d1fbb7ea482
Part 1 - Make GetCaptionSide() and HasSideCaption() const methods. r=layout-reviewers,mats
https://hg.mozilla.org/integration/autoland/rev/33171dca5ccd
Part 2 - Split and rename nsTableWrapperFrame::OuterBeginReflowChild() into two methods for caption and inner table. r=layout-reviewers,mats
https://hg.mozilla.org/integration/autoland/rev/48895a7f84a6
Part 3 - Rename OuterDoReflowChild() to ReflowChild() for nsTableWrapperFrame. r=layout-reviewers,mats
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: