Closed Bug 1690947 Opened 10 months ago Closed 6 months ago

Decision tasks can fail when an optimized task is about to expire

Categories

(Firefox Build System :: Task Configuration, task)

task

Tracking

(firefox91 fixed)

RESOLVED FIXED
91 Branch
Tracking Status
firefox91 --- fixed

People

(Reporter: glandium, Assigned: ahal)

References

Details

Attachments

(2 files)

The decision task JTtpfthTQLKTtNROpJhCPQ failed with:

[task 2021-02-05T01:57:02.454Z] `task.dependencies` references tasks that expires
[task 2021-02-05T01:57:02.454Z] before `task.deadline` this is not allowed, see tasks: 
[task 2021-02-05T01:57:02.454Z]  * exXDr2J5TuSouPw0ax-I-A,
[task 2021-02-05T01:57:02.454Z] All taskIds in `task.dependencies` **must** have
[task 2021-02-05T01:57:02.454Z] `task.expires` greater than the `deadline` for this task.

The task in question, exXDr2J5TuSouPw0ax-I-A, has:

expires	"2021-02-05T02:52:40.752Z"

which, as of writing, is now the past, so this is going to work out ok for the next attempt at the same task graph, but was in the future back then but not enough in the future that all tasks' deadlines would be before that.

Duplicate of this bug: 1712333
See Also: → 1618067

This moves the return value of the old task to a new 'state_task' function and
updates consumers. We'll be using other parts of the status in later patches in
the stack.

Attachment #9223081 - Attachment description: WIP: Bug 1690947 - Take dependent deadlines into account when deciding whether to replace a task → WIP: Bug 1690947 - [taskgraph.optimize] Take dependent deadlines into account replacing a task
Assignee: nobody → ahal
Status: NEW → ASSIGNED
Attachment #9223082 - Attachment description: WIP: Bug 1690947 - [taskgraph] Return full status in util.taskcluster:status_task → Bug 1690947 - [taskgraph] Return full status in util.taskcluster:status_task, r?#taskgraph-reviewers!
Attachment #9223081 - Attachment description: WIP: Bug 1690947 - [taskgraph.optimize] Take dependent deadlines into account replacing a task → Bug 1690947 - [taskgraph.optimize] Take dependent deadlines into account when replacing a task, r?#taskgraph-reviewers!
Pushed by ahalberstadt@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9de86787dc53
[taskgraph] Return full status in util.taskcluster:status_task, r=taskgraph-reviewers,aki
https://hg.mozilla.org/integration/autoland/rev/89909afc3777
[taskgraph.optimize] Take dependent deadlines into account when replacing a task, r=taskgraph-reviewers,bhearsum

This busted bootstrap via e.g. mach artifact toolchain because it uses should_replace_task but its call site hasn't been updated.

Flags: needinfo?(ahal)

mach taskcluster-load-image is probably similarly busted.

Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Regressions: 1715493

This got fixed in bug 1715493 and is currently on central. Thanks Emilio!

Flags: needinfo?(ahal)
See Also: → 1720563
You need to log in before you can comment on or make changes to this bug.