Closed Bug 1691831 Opened 2 months ago Closed 2 months ago

After browsing yahoo.com with VO, Firefox indefinitely hangs

Categories

(Core :: Disability Access APIs, defect, P1)

Unspecified
macOS
defect

Tracking

()

RESOLVED FIXED
87 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox85 --- unaffected
firefox86 --- unaffected
firefox87 --- fixed

People

(Reporter: eeejay, Assigned: eeejay)

References

(Regression)

Details

(Keywords: regression, Whiteboard: [mac2020_2])

Attachments

(1 file)

It looks like this is caused by invalid offsets passed to the attributed text getter. Those offset values should be clamped to the character count of containers.

Severity: -- → S2
Priority: -- → P1

I tried to come up with a good test for this, that reproduces the issue in a demonstratable way, but couldn't.

Pushed by eisaacson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7daa9a759d26
Clamp offsets to character count in HyperTextIterator. r=morgan
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
OS: Unspecified → macOS
Whiteboard: [mac2020_2]
You need to log in before you can comment on or make changes to this bug.