Closed Bug 1691854 Opened 7 months ago Closed 7 months ago

Hamburger menu icon shows update badge (green arrow) but Proton app menu doesn't have a "Restart to update" menu item

Categories

(Firefox :: Menus, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox87 --- verified

People

(Reporter: cpeterson, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-hamburger-menu] )

Attachments

(1 file)

Steps to reproduce

  1. I set browser.proton.appmenu.enabled pref = true and restarted Nightly.
  2. Later that day, I noticed the Nightly update badge (green arrow) overlaid on the hamburger menu icon.

Expected result

At this point, I usually open the hamburger menu and click the "Restart to update Nightly" menu item.

Actual result

But the Photon app menu no longer includes a "Restart to update Nightly" menu item.

Here's a screenshot of the current Proton app menu.

I think this is a dupe of bug 1690662.

(In reply to Asif Youssuff from comment #2)

I think this is a dupe of bug 1690662.

I don't think this bug is a dupe of bug 1690662. IIUC, that bug will add an app menu section "for things like update banners". But it doesn't necessarily mean that the "Restart to update Firefox" menu item has been implemented. After bug 1690662 is fixed, I can re-test this bug.

Depends on: 1690662

The patch in bug 1690662 adds these.

Severity: -- → S3
OS: Unspecified → All
Priority: -- → P3
Hardware: Unspecified → Desktop
Whiteboard: [proton-hamburger-menu]
Version: unspecified → Trunk

Verified fixed by bug 1690662

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

I can reproduce this bug on Fx 87.0, with proton on, using Win 10.
According to the fix of the bug 1690662, I verified - Fixed in latest Nightly 90.0a1 (2021-04-19), Fx 89.0b2, Fx 88.0 and Fx 87.0b9,with proton on, using Windows 10x64 and Mac 11.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.