Closed Bug 1691859 Opened 2 years ago Closed 2 years ago

Emulate mix-blend-mode without KHR_blend_equation_advanced in WR when possible

Categories

(Core :: Graphics: WebRender, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
87 Branch
Tracking Status
firefox87 --- fixed

People

(Reporter: lsalzman, Assigned: lsalzman)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Multiply, screen, and exclusion blend modes can be implemented with either basic blending or dual-source blending. It would be nice to at least specifically handle multiply without requiring the KHR_advanced_blend_equation extension or going through the brush_mix_blend shader.

We don't actually need to use brush_mix_blend or KHR_blend_equation_advanced for multiply, screen,
and exclusion modes. Screen and exclusion can be done with simple blending, and multiply can be
done with dual-source blending. Since multiply is the most common mix-blend mode, and dual-source
blending is also common on the desktop with our ANGLE driver, this should be a significant boost
for mix-blend-mode performance for us across.

Blocks: 1692031
Blocks: 1684781
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/378542fd1298
Emulate mix-blend-mode without KHR_blend_equation_advanced in WR when possible. r=gw
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
Regressions: 1693998
Regressions: 1695807
You need to log in before you can comment on or make changes to this bug.