Closed Bug 1692130 Opened 1 year ago Closed 1 year ago

JSFunction::delazifyLazilyInterpretedFunction is treated as "Interpreter" or "Jit" time in the profiler - would a different category be more appropriate?

Categories

(Core :: JavaScript Engine, task, P1)

task

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: mstange, Assigned: arai)

References

Details

Attachments

(1 file)

Profile: https://share.firefox.dev/2Z3vp9B

In this profile we spend a lot of time in JSFunction::delazifyLazilyInterpretedFunction, but this is not obvious when you look at the JS categories in the profiler sidebar. Only the "script delazify" subsection of CompileLazyFunctionToStencilImpl is annotated with the "Parsing" profiler category. The rest of JSFunction::delazifyLazilyInterpretedFunction inherits a category based on where it's called.

Would it make sense to apply the "Parsing" category at some other point in the callstack? Or maybe a new / different subcategory, if "Parsing" is not a fitting name?

Yikes. This is actually a regression. The time outside of the "Parsing" should be near zero.

@arai, this looks like a big problem with the scope-snapshot stuff and we probably need a different design.

Severity: -- → S2
Flags: needinfo?(arai.unmht)
Priority: -- → P1
Flags: needinfo?(arai.unmht)
Regressed by: 1690277
No longer regressed by: 1690277
See Also: → 1690277

about the category, yes, that should be categorized as something around frontend.
will look into it.

then, about the regression, I've asked backing out the bug 1690277 patch.

bug 1687095 touches the code around DelazifyCanonicalScriptedFunctionImpl

Depends on: 1687095
Assignee: nobody → arai.unmht
Status: NEW → ASSIGNED
Flags: needinfo?(arai.unmht)
Pushed by arai_a@mac.com:
https://hg.mozilla.org/integration/autoland/rev/d69774c978c6
Move DelazifyCanonicalScriptedFunction into frontend, and categorie the entire function as delazification in profiler. r=tcampbell
Flags: needinfo?(arai.unmht)
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
You need to log in before you can comment on or make changes to this bug.