Closed Bug 1692698 Opened 10 months ago Closed 10 months ago

When maximized, the first tab should still show a gap between the tab and the edge of the window

Categories

(Firefox :: Theme, defect, P1)

defect

Tracking

()

VERIFIED FIXED
87 Branch
Tracking Status
firefox87 --- fixed
firefox88 --- verified

People

(Reporter: jaws, Assigned: jaws)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Whiteboard: [proton-tabs-bar])

Attachments

(1 file)

This gap should still respond to clicks as though the click is targeted at the first tab, to keep Fitts' Law working. Also, the border-radius on the <tab> should be removed otherwise the top-left corner of the window (LTR) misses the click target.

Summary: When maximized, the first pinned tab should still show a gap between the tab and the edge of the window → When maximized, the first tab should still show a gap between the tab and the edge of the window
Duplicate of this bug: 1692606
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/874f2abf1d4c
On maximized window, show a gap between the first tab and the window edge, while continuing to support Fitts' Law. r=dao
Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 87 Branch
Regressions: 1693701

On Windows 10: The gap is between the first tab and the edge of the window is visible but clicking on that gap is not targeting the first tab.
https://imgur.com/a/3D4GLX8
On Windows 7: The gap is between the first tab and the edge of the window is visible and clicking on the gap is targeting the first tab.
On Ubuntu 20.04: The gap is between the first tab and the edge of the window is visible and clicking on the gap is targeting the first tab.
On macOS 10.15: Not sure if this is applicable since (Close/Minimise/Maximise) button are left aligned.

Are these results the expected behaviour for every OS?
Thanks.

Flags: needinfo?(jaws)

Can you please file a bug for the Windows 10 issue? The other operating systems sound good to me.

Flags: needinfo?(jaws) → needinfo?(hani.yacoub)

Verified as fixed on Windows 7 x64, Ubuntu 20.04 x64 and on macOS 10.15 on the latest Firefox Nightly.
Loogged Bug 1699726 for the issue on Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: needinfo?(hani.yacoub)
You need to log in before you can comment on or make changes to this bug.