All users were logged out of Bugzilla on October 13th, 2018

flash site crashes mozilla when *no plugins are installed*

RESOLVED WORKSFORME

Status

()

P1
critical
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: jwz, Assigned: peterl-bugs)

Tracking

({crash})

Trunk
Future
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
about:plugins reports only "libnullplugin.so"

    % ls /usr/lib/mozilla*/plugins/

    /usr/lib/mozilla-1.1b/plugins:
    java2/            libnullplugin.so* 

    /usr/lib/mozilla/plugins:
    java2/            libnullplugin.so* 

Going to http://www.zeromancer.com/zmr.htm causes a framset with a few Flash
plugin icons to appear -- and then Mozilla crashes.  If it doesn't crash right
away, hit reload and wait for it to finish.  I had to do it three times once,
but usually it crashes by the second time.

Mozilla 1.1b, from the mozilla-1.1b-0 RPM on mozilla.org.
Red Hat Linux 7.2, 2.4.9-13smp #1 SMP


% gdb /usr/lib/mozilla-1.1b/mozilla-bin
GNU gdb Red Hat Linux (5.2-2)
...
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
(gdb) r  http://www.zeromancer.com/zmr.htm
Starting program: /usr/lib/mozilla-1.1b/mozilla-bin
http://www.zeromancer.com/zmr.htm
[New Thread 1024 (LWP 7122)]
[New Thread 2049 (LWP 7152)]
[New Thread 1026 (LWP 7153)]
[New Thread 2051 (LWP 7154)]
[New Thread 3076 (LWP 7174)]
[New Thread 4101 (LWP 7175)]
[New Thread 5126 (LWP 7188)]
[New Thread 6151 (LWP 7198)]
[New Thread 7176 (LWP 7222)]
[New Thread 8201 (LWP 7223)]
[New Thread 9226 (LWP 7224)]
[New Thread 10251 (LWP 7225)]
[New Thread 11276 (LWP 7226)]
[New Thread 12301 (LWP 7227)]
[New Thread 13326 (LWP 7228)]
[New Thread 14351 (LWP 7230)]
[New Thread 15376 (LWP 7234)]
[New Thread 16401 (LWP 7235)]

Program received signal SIGILL, Illegal instruction.
[Switching to Thread 1024 (LWP 7122)]
0x081af178 in ?? ()
(gdb) bt
#0  0x081af178 in ?? ()
#1  0x41423863 in nsPluginStreamListenerPeer::SetUpStreamListener ()
   from /usr/lib/mozilla-1.1b/components/libgkplugin.so
#2  0x414225ef in nsPluginStreamListenerPeer::OnStartRequest ()
   from /usr/lib/mozilla-1.1b/components/libgkplugin.so
#3  0x40781d4f in nsHttpChannel::OnStartRequest ()
   from /usr/lib/mozilla-1.1b/components/libnecko.so
#4  0x40799e5f in nsOnStartRequestEvent::HandleEvent ()
   from /usr/lib/mozilla-1.1b/components/libnecko.so
#5  0x40736dfb in nsARequestObserverEvent::HandlePLEvent ()
   from /usr/lib/mozilla-1.1b/components/libnecko.so
#6  0x40183763 in PL_HandleEvent () from /usr/lib/libxpcom.so
#7  0x40183bb0 in PL_ProcessEventsBeforeID () from /usr/lib/libxpcom.so
#8  0x407e2cc1 in processQueue ()
   from /usr/lib/mozilla-1.1b/components/libwidget_gtk.so
#9  0x40150de1 in nsVoidArray::EnumerateForwards () from /usr/lib/libxpcom.so
#10 0x407e2cff in nsAppShell::ProcessBeforeID ()
   from /usr/lib/mozilla-1.1b/components/libwidget_gtk.so
#11 0x407e9e81 in handle_gdk_event ()
   from /usr/lib/mozilla-1.1b/components/libwidget_gtk.so
#12 0x4036b10f in gdk_wm_protocols_filter () from /usr/lib/libgdk-1.2.so.0
#13 0x4039b055 in g_main_dispatch (dispatch_time=0xbffff7f0) at gmain.c:656
#14 0x4039b659 in g_main_iterate (block=1, dispatch=1) at gmain.c:877
#15 0x4039b7e8 in g_main_run (loop=0x822d978) at gmain.c:935
#16 0x402b7203 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#17 0x407e2a2e in nsAppShell::Run ()
   from /usr/lib/mozilla-1.1b/components/libwidget_gtk.so
#18 0x407c5eae in nsAppShellService::Run ()
   from /usr/lib/mozilla-1.1b/components/libnsappshell.so
#19 0x08052b85 in main1 ()
#20 0x08053457 in main ()
#21 0x404f8336 in __libc_start_main (main=0x805330c <main>, argc=2, 
    ubp_av=0xbffffa94, init=0x804cc28 <_init>, fini=0x8054b70 <_fini>, 
    rtld_fini=0x4000d2fc <_dl_fini>, stack_end=0xbffffa8c)
    at ../sysdeps/generic/libc-start.c:129

Comment 1

16 years ago
Jamie, could you please try the latest nightly
http://ftp.mozilla.org/pub/mozilla/nightly/latest, talkback enabled build?
there were several changes in libgkplugin.so since 1.1b,
at least I cannot reproduce the crash using Gecko/20020917 debug or release builds.
thanks.

Updated

16 years ago
Keywords: crash

Comment 2

16 years ago
Shrir: could you give this one a whirl?

Comment 3

16 years ago
reassign
Assignee: beppe → peterl

Updated

16 years ago
Priority: -- → P1
Target Milestone: --- → Future

Comment 4

12 years ago
andrew can you test? (would be nice to just "expire" some of these old flash bugs)

Comment 5

12 years ago
WFM per comment 1
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.